Index.html changes ignored by Safari and Chrome browsers

I have been making changes to an index.html file and for some reason both Safari and Chrome have begun ignoring these changes. Yesterday I did not have this issue.

I have done the following (many times) to try and remedy this behavior:

clear history/cache
restarted both browsers
restarted computer
repeat …

None of these things have resolved this issue.

Research has provided no help that I could find.

The site folder in use is empty of all files save for the index.html file, error_log and a few empty folders.

When either browser launches it shows the previous file I had worked on even though history has been cleared. The actual index.html file within the site folder is simply ignored.

Needless to say, this has brought my work to a halt.

Any help with this issue will be greatly appreciated.

Thank you.

I forgot to add that if I right-click on this index.html file and choose either Safari or Chrome the webpage will open revealing the new markup changes.

I have not added/removed any extentions or anything of that sort to either browser.

I have no idea what may be causing this behavior.

Thanks.

Did you take a look at the Browser developer tools from where the file is loaded and with which status?

1 Like

Not wanting to be too obvious, but you did remember to save the file with the changes before you tried to view it? Experience can be an unforgiving tutor.

Thanks for your post.

In Safari using the dev tools I used both

Show Page Source and
Show Page Resources

both showed what is seen in the browser, but not what is in the website folder.

For instance the h2 tag shows 999 when in fact it should be showing 777

So the browser is not showing the changes.

Thanks.

Thanks for your comments.

No, you are correct in that that could easily happen (and has …), but I am saving and double-checking the index file that is actually in the site folder with my ftp app - Transmit.

I’m at wits end with this problem. Absolutely nothing seems to fix it and I have tried Safari, Chrome and now FireFox - all with the same results.

I have not idea!

Thanks!

What is further puzzling to me is if the cache/history have been cleared and the webpage is still showing a webpage that does not exist - where is this webpage coming from? It has to be cached somewhere for it to appear?

I thought I knew a bit about how all of this works, but this has proven that I know very little about any of this.

I have gone so far as to place a test page on another of my websites and the file loads perfectly the first time it is launched. But all changes to this same file are ignored.

I’ll keep diggin’.

Please try the following:

Open Chrome
Use Menu „More Tools“ → „Web Developer Tools“
Choose the „network“ tab
Open your page.

Now the index.html should appear in the list of loaded files in the network list.
There you can see the status and the full path from where the file is loaded

One thought, possibly very remote, but what the heck…

My host (hostgator) backs up my site periodically. I have no idea exactly how they do that backup, but during that time, which can take a couple hours, they seem to be serving my web from “somewhere else”. That is, I can make changes that don’t seem to happen, I can completely delete what I think is my whole directory of files, yet from the browser I’m seeing the files that were there a few hours ago. Usually it’s fixed by the time I’m pulling my hair out.

The answer for me is to wait a bit and try again later. Like I say, I have no idea if this is your situation or not, but it sounds familiar.

Thank you for your help.

This is what I see from your instructions:

The index file in the folder actually shows the following:

Clearly what the browser shows is not the updated index file.

Thanks again.

Do you have a screen grab of the dev tools window after you’ve done the reload it’s requesting?

Thanks for your input.

Funny you should bring this up because I did contact my server guru’s, but I when I sent the support ticket I was prompted to log back in. This was a ‘Huh?’ moment, but I dismissed it.

So, now, I’m thinking that you may be on to something. In addition, after I send off a support ticket I immediately get an email notifying me that they received my ticket. This did not happen, so yeah, I think you may have nailed the problem.

I was tooting along just fine with my work yesterday, but I have chased my tail ALL DAY LONG today. I absolutely hate wasting a day like this.

Thanks, you may have solved the problem. I will indeed wait a few hours and see what goes down later.

Are the grabs that I submitted earlier what you were asking about? If not, let me know and will resend whatever you ask for.

Here’s another grab for you just in case:

Thanks!

The previous screenshot didn’t show the response you see in the lower-right quadrant for your index.html. It’s interesting that it’s showing a 304 response, or ‘Not modified’. You’d usually expect to see a 200 if it was responding correctly.

I’ve not read a lot of it, but this may prove informative https://developer.mozilla.org/en-US/docs/Web/HTTP/Status/304

Got it! Yes, I am aware of the 200 response as being what we want to see, but had no idea about the 304 status response.

I just sent off a support ticket to server buddie’s so when they get back to me I will show them this 303 grab.

What a way to learn about 304 status! Ha!

Thanks again for your help.

Out of interest, and assuming you have control over it, have you tried rebooting your router?

Good idea! I will do that right now.

I have just heard back from my server friends that they said they have been up all day long so this was not the problem. I will know more later.

I will reboot the router and get back to you.

Okay, I rebooted the router. No help, still seeing ‘Status 304’.

Have not heard back from the server guru’s yet.

Thanks for your help.

Solution Found!

It was a server side problem. It had something to do with a vendor (of some sort) making an update and this caused this issue to ripple across vendor land, my part of it anyway.

I want to say THANK YOU! to everyone who pitched in to help me with this issue. I learned a lot during this down time and that’s always a good thing. Each and every markup change is now being recognized as it should be. What’a ride!

So, perhaps the bottom line should be this: If your webpage is not updating as it normally should, then:

  • 1 Make certain that you saved the file before uploading and refreshing the webpage;
  • 2 Check your browser dev tool to determine the status of your newly uploaded file;
  • 3 If this status is ‘304’ then contact your server guru’s;
  • 4 Find something else to do until you hear back from them.

Number 4 if optional. Ha!

Cheers to all!

4 Likes