Images disappearing upon FTPing

A .png file that I can preview on my Desktop, disappears after FTPing (Filezilla).

When I ftp a .png file to my web image file it doesn’t appear.
So, I ftp it back to my Desktop and click on it it says “No Preview Available”.

I’ve done this same thing successfully (uploaded files via Filezilla) a thousand times, but today no images after uploading.

It’s so irritating when something that should takes 30 seconds, takes up much, much more time.

Any remedy would be appreciated.

Hm, sounds odd. Can you ftp the image to any other location?

Thanks for replying. Yes, it’s a mystery that needs solving.
Your FTP question is a good one.
However, I don’t know where else I can FTP too.

I just mean to any other folder on your site.

Yes, I’ve tried other folders.
Sam issue.

OK, have you tried a different image? It’s just a way of making sure it isn’t the image itself that’s the problem.


This sounds like the MIME Type for .png may have gotten messed up on the FTP server. Can you see any other PNG files in any of the folders you have access? If you can’t it is either you did not have any other PNG or that none of the PNG’s are showing which would point to the MIME type.