I'm getting this error while creating table in phpmyadmin. Please Help

I’m using phpmyadmin 4.5.1 and I’ve created a database called mydb and set collation to utf8_bin and I’ve created a table called users with 8 fields, when I hit save it is giving me this error.

Show us the table layout that you’re trying to create.

Nothing to worry, I’ve solved it. Thanks :blush:

I’m interested to know what you did to solve it.


I’m not interested to tell you :unamused:

Just kidding :smile:

Well, when you set an field to A_I (Auto Increment) , window pop-ups in your screen which is as follows:

In the Size field I had inserted 30, and when I click it was showing the error, So I tried to not add any value, and clicked save. It saved correctly.
And error solved. :wink:

I didn’t see your CREATE but I’m guessing:

There is a field NOT NULL - but must be at least an empty string

It can work. Buy IMHO you should consider whether or not a NULL might be better

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.