Im getting Error 521

Im getting Error 521 on my site https://share-ask.com/ ,host says problem is which cloudflare can you plz help

It is a long time since I have used CloudFlare and have vague memories that there is an option to temporarily disable CloudFlare’s cache.

It is necessary to login to CloudFlare to toggle this option.

How To Disable CloudFlare - CloudFlare Guide

How To Disable CloudFlare - HostMonster cPanel account](https://my.hostmonster.com/hosting/help/cloud-flare-guide)

The error page says the error is with your host.

If you are the owner of this website:
Contact your hosting provider letting them know your web server is not responding. Additional troubleshooting information

Have you read the additional troubleshooting information?

1 Like

I checked by entering the following URL and selected Verbose into the following and the server is set to Cloudlflare:

https://domaincheck.tk/test?

Results from above:

CloudFlare requires the domain to point to CloudFlare.

CloudFlare has the option to ignore their CloudFlare cache and to use the original host.

It does. If it didn’t you wouldn’t see an error from CloudFlare.

It will be interesting to see what the actual host returns when cache is disabled. From what I can gather 521 means your actual host (behind CloudFlare) is having problems.

If you know the IP of your actual server and have access to a command line with cURL you can also try the following:

curl --resolve share-ask.com:443:{actual IP of the server behind cloudflare} https://share-ask.com/

That will show the actual response of the server if there were no CloudFlare.

2 Likes

The original Post stated that :

host says problem is which cloudflare

I thought it was better if CloudFlare was isolated from the problem and the host could be tested.

I have also noticed that once the domain has been propagated it often only takes minutes to redirect the domain. This might be necessary if the hosting provider insists it is not their fault.

Oh, the host said that? Must be true then. Because hosts never point the blame at someone else so they don’t have to do anything. Oh wait…

Agreed. Hence my cURL suggestion which does exactly that :slightly_smiling_face:

2 Likes