IIS 7, FastCGI, PHP & maxInstances Oh My!


I have a site, works fine under IIS 7 using PHP via FastCGI. FastCGI has a config option called ‘maxInstances’. The default is 4, although the recommendation is 10 x # processors (which would be 80 in my case). If I change ‘maxInstances’ from the default I see a proportional # of 500 status codes via FastCGI from the server when under load. I cannot fathom the reason.

Is there a IIS 7 expert who can explain why this change, when all other settings are at default for FastCGI, should have such a detrimental effect?