IE10 session variables not being set

Hello, all,

I’m creating a form that submits via AJaX (jQuery $.post()) and I’m attempting to use a captcha-less method of preventing automated submissions (a combination of simple math and a honeypot.)

I’m doing this in ColdFusion. Before the page that contains the form loads, I’m creating a ColdFusion array of math questions and the corresponding answers. After one has been randomly selected, the question and it’s correct answer are inserted into session variables, so that when the form is submit to a CFC, the correct answer in the session variable is compared to the user input answer - if they match, WOOT WOOT!

This is working flawlessly in FireFox and Chrome - and, oddly enough, not at all in Internet Explorer 10. Matter of fact, when I do a CFDUMP of the session scope from the CFC, there are lots of session variables, but not the ones I’m setting on the form page (in IE - they are there in FF and Chrome.)

The dev server is already listed in the Trusted Sites list. I’m not CURRENTLY using SSL/TLS - this is just development, not production.

Any ideas on what could be preventing IE from seeing the session vars that are being set in the form page??



Okay… I have a better idea of what is going on… I just don’t know how to fix it.

For some stupid reason, every time the AJaX submits the data to the form in the CFC, ColdFusion Server is re-issuing the CFID. DIfferent CFID means a different session. So the session vars set when the form page loads are gone by the time the form submits to the CFC.

This isn’t happening in FireFox or Chrome. Just IE.

Anyone have any thoughts on how to correct this?



The only thing I can think of right now is that IE isn’t accepting a Cookie?

I’ve gone into my IE settings and set it to accept all cookies.

I think IE has an issue with the browser being on “” but submitting via AJaX via “…/…/components/this.cfc?var=foo&idx=1”. I suspect that IE considers it a different session, so CF gives it a new session ID.

That’s my best guess, so far.



EDIT: Nope… completely incorrect. The search continues… and the hair-yanking… and the sharp connection twixt desk and forehead.

I’m not sure what all the “Internet Options” on my dev system were set to (or how they got that way), but I clicked on “Reset all settings to default”, and now it’s working.



1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.