I can't get mysqlimport to work after using --all-databases with mysqldump

I have a new computer and backed up my files with the following command:

mysqldump -u root -p --all-databases > full_backup.sql

this worked great and I placed the backup in my new machine.

I have been trying to use the following statement to import my file back in, however it is not working:

mysqlimport -u root -p --all-databases full_backup.sql

I also tried using…

mysqlimport -u root -p full_backup.sql

and this still does not work. I am trying to import all my databases at once on my new machine. Thank you for reading my post and any suggestions would be awesome. --Ben

Have you tried this?
mysql -u root -p -h <full_backup.sql
The dump in .sql format is really a text file containing all the necessary commands you would manually supply to recreate the database(s); as if you were typing at the command line.

Thank you ParkinT. I used " mysql -u root -p < full_backup.sql " and I placed my backup file in the right location this time and it worked like a charm–my databases are all there. -Ben

I am very happy to be able to help.
Welcome to Sitepoint. I encourage you to visit often, not only to read and learn but also to contribute your own knowledge and experience for others.

Have fun.