How to unset open_basedir in php.ini

How to unset “open_basedir” in php.ini? And why would a wordpress site have this value set?

Actually, I don’t know what open_basedir is, but PHP WARNING is telling me to unset it…

CURLOPT_FOLLOWLOCATION cannot be activated when in safe_mode or an open_basedir is set

PHP is also giving me the warning …

open_basedir restriction in effect.

I’m guessing unsetting open_basedir would fix both? I already have safe_mode disabled.

And why would a wordpress site have this value set?

If it is a hosted site, with shared hosting they will very likely be using safe_mode = on

This stops you accessing files you should not be able to get hold of, like those on the same server but not in your directory.

What is more, the hoster may well have decided to stop anyone messing with that safe_mode = on setting by adding ini_set() to the list of disabled functions.

I’m not sure if I am answering your exact question, or if I’m muddying the waters even more for you.

If it’s apache configured to run mod_php, you can turn off open_basedir in a .htaccess file with php_admin_value open_basedir none