How to solve imported issue into database?

The field ‘Address 2 - Type’ is set as NOT NULL and does not have a default value.
Field ‘Address 2 - Formatted’ doesn’t have a default value

Which preferences should be set to solve imported issue?
Need help.

It’s a bit difficult to tell with so little information (such as your database table layout and a sample of the data you’re trying to import into it), but a thought:

This states that the column must contain something (it’s not allowed to be null), and you’re trying to import a blank field into it. Because you don’t have a default value, your database engine (whichever it is) is rejecting the row.

Either set a default value, or allow the column to contain null.

Please find the following settings:
Null is Yes Default is NULL
Which settings should be to import without an issue?

The error message suggests that Null is No. If it’s actually yes, I don’t know what the issue is. Can you do a SHOW CREATE TABLE tablename and post the results?

make sure every column is nullable (i.e. do ~not~ specify NOT NULL)

whether you specify a default value is up to you

It is working now.
NULL is Yes
Default is NULL
Thank you for the message.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.