How to prevent Photoshop CS5 from Replacing All Missing Fonts

Can someone tell me how to disable this? Everytime I open a PSD it does this and the font needs to look the way it is, regardless if I have the font installed or not.

I looked under Preferences | Type and there’s nothing there to disable it and I can’t find anything on Google.

Everytime I open a file, it waits for about 30 seconds then screws up all the fonts and I have to undo it each time. What a PITA.

That’s interesting because I’m running the same. Have you run the install extensions from the Menu in FontAgent Pro (I’m assuming you are using version 4 as 3 has compatibility issues with Snow Leopard). Depending on which order you installed FA Pro and the Adobe Suite it may or may not have installed the extensions.

I do have to say that running the CS5 suite is more painful than the CS3 suite before it. It didn’t seem to balk at the fonts nearly as much.

I tried re-installing the extensions again from the File menu, and restarted Photoshop and am getting the same thing. I don’t get why PS has to be so stupid and just leave the fonts alone then if I go to edit them it will say which font is missing.

Okay, I’ve reset all of my Dialog Boxes under the Preferences menu and it is STILL replacing all of the missing fonts upon opening a PSD.

Uggh, this is soo annoying. I have wasted so much time having to redo images because I didn’t realize the font had been replaced. (it also causes PS to hang for a while after I open PSDs)

Do you still have a text box prompt when you open the file? If you don’t you may have selected the option to turn off the prompt. If you set the option to always update the fonts then PS will be doing this action by default every time (which you then are undoing).

You can reset the dialogue box by going to Preferences>General>Reset All Dialogue Boxes.

Just out of interest what platform are you on: mac/pc and are you running any font management program?

Mac OS X (Snow Leopard) and FontAgent Pro