How to fix internal links contain nofollow attribute

Im getting warning to fix internal links contain nofollow attribute ,but im not sure how to fix it internally ,plz guilde

Below are few internal links

One URL is quite sufficient, @Atik1.

More useful would be a better description of your problem. Where is the warning coming from, and what, exactly, does it say?

K

warning is coming from semrush PFA warning

Sorry, I don’t use SEMrush, and that screenshot means nothing to me.

What is the error message? What does it say is wrong with these links which needs to be fixed?

It says i’ve no followed my internal links which needs to be fixed

Then remove the “nofollow” attribute from those links - if you are sure that you do want search engines to follow them.

If you had good reason to make them “nofollow”, then leave them that way.

1 Like

Yes, it seems the tool is assuming that because they are internal links they should not be nofollow.

The tool does not have a brain that knows what your intentions are, you do. If you know better, ignore those warnings and consider them more as “should look into these” messages rather than “must fix these” messages.

2 Likes

but my site is default nofollow so how do i fix dis

As both @Mittineague and I have tried to explain, if you have chosen to make those links nofollow then there is nothing to fix; nothing is broken.

SEMrush is drawing attention to the fact that you have the nofollow attribute on internal links (which is unusual but not wrong), in case you have done this by accident and want to change it. If you are happy with those links being nofollow, then you don’t need to take any action.

but if entire site is nofollow is it practicall to find so many links ,or what is way forward

Do you want these links to be nofollow or not? Why did you create them like that in the first place?

If you want them to be nofollow, leave them as they are and stop worrying about it.

If you don’t want them to be nofollow, then you will have to remove the nofollow attribute.

I created nofollow to whole site to avoid OBL getting my juice , if entire site is nofollow is it practicall to find so many links ,or what is way forward

@Atik1: as I said above

I see no other option. Either you need to live with things as they are, or you need to change them. How did you set all links to nofollow in the first place? Is this a WP setting? (I don’t use WP.) If so, can you find an option to set only external links to nofollow?

Tnx

fyi im using https://wordpress.org/plugins/seo-internal-links/ which we can set external* links to nofollow/dofollow ,this is not WP setting but plugin is putg nofollow on my internal-link so dats issue

In that case, it would seem that the plug-in is not working correctly, and I would suggest that you contact the author for support. (There is also a link to a forum.)

Other than that, I can only suggest you remove the plug-in.

Personally, I would steer well clear of a plug-in which has only seven reviews and three of them are bad; that is not an indication of quality, IMHO.

2 Likes

sorry im using dis www.prelovac.com/products/seo-smart-links/

In that case, are you sure that you have set it correctly to allow links to your own domain?

Nofollow whitelist – Allows you to specify a whitelist of domains that you do not want to add ‘nofollow’ attribute to (for example for your own sites).

PFA settings

So the answer appears to be no, you haven’t added your domain to the whitelist. (It would have been easier if you had just said that. )

Does it solve your problem if you do?

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.