How to enable permalinks for wordpress on windows server

Hi, I have hosted my website on windows server 2008 but while trying to enable permalinks on wordpress I am getting 404 error, I tried enabling mod_rewrite from httpd.conf file but it doesn’t seem to work.
What could be the issue please guide me.


M$ has attempted to duplicate mod_rewrite in at least two versions on IIS servers however I believe you’ll need to wait for an M$ expert (like wwb99) for a definitive answer - because my advice would be to use an Apache server.

In the mean time, you may want to check the file permissions on your .htaccess equivalent file where WP would have attempted to write its code.



i have not uploaded any .htaccess file i have just tried to write rewrite rule in web.conf file but it didnt work
I tried following the tutorial here

The IIS url rewrite stuff is just as powerful as mod-rewrite.

It should work if you are on windows server 2008 if you apply the above linked tutorial. I would be certain I could write to web.config – that is often not the case between file permissions and UAC settings. The other thing to check into with the host is if they have the url rewrite module enabled for your site.

That link does work – we’ve got half a dozen blogs running on IIS using that same guidance.