How to disallow these types of pages from Google index

Google has suddenly started indexing /wp-includes types of pages.
How do I deindex these types of pages?
Please help me…
Unwanted%20pages

Sounds like you either didn’t specify or simply removed the “Options -Indexes” directive in your .htaccess file. If you never had one of these files, it is easy to setup.

  1. First go to your site and see if you can see the files being listed in your /wp-includes folder. You can do this by going to https://yoursite.com/wp-includes. If it shows a list of all the files in there, then yeah your options indexes directive needs to be put into place.

  2. Open a text editor like sublime text, notepad++, atom etc and put in it “Options -Indexes”. Then save it as .htaccess. Notice the file starts with a period. Make sure it is named this and starts with that period.

  3. Upload the file to the root directory of your website.

  4. Now revisit that URL in step 1. It should now prevent you from seeing the list. Good, now the search engines won’t see it.

  5. The next step is to go to Google search console and ask Google to remove any URLs it has already indexed. You can do this or let them drop off the index naturally, but this can take a bit of time so I would go with the removal tool. You can learn more about it here… https://support.google.com/webmasters/answer/1663419?hl=en

The removal tool is temporary but that will give Google time to then attempt to reindex and notice it is unreachable and skip indexing it again.

I hope that helps. :slight_smile:

4 Likes

thanks for your kind response

Use disallow code to stop search engine to crawl a particular page.