How to change site url?

In my hostgator wordpress installation

Wordpress url: http://somedomain.com/wp/
Site url: http://somedomain.com/wp/ ----> this opens in browser.

I changed this to
Wordpress url: http://somedomain.com/wp/
Site url: http://somedomain.com ----> Now it shows Under Construction in browser

How do I make the site url as to my domain name ? what changes I require here

If you are using your hosting provider’s managed WordPress hosting, did you contact them for help here?

Not contacted hostgator yet.

its my domain… all I want to do is to change my wordpress site url

from url: http://somedomain.com/wp/

to http://somedomain.com

where to change this ? Is it a host settings or wordpress settings ?

What domain is showing in these?

Settings > General > WordPress Address (URL)

Settings > General > >Site Address (URL)

Wordpress url: http://somedomain.com/wp/
Site url: http://somedomain.com/wp/

don’t want to disclose domain name.

Try changing them to this:

Wordpress url: http://somedomain.com
Site url: http://somedomain.com

Then save your changes at the bottom. See if that helps your url issue.

Just don’t put anything in Directory do it blank.

Thanks

@anarojasblogger

could not get you.

There is a /wp Directory in hostgator wordpress installation server. Do you want to remove all contents from this wp directory ?

I think this article will help. https://codex.wordpress.org/Changing_The_Site_URL

Hi :slight_smile: And consider migrating Your site to https, I advise you to switch to a secure connection, search engines are the sites rank better. I last week moved to https, what You suggest.

I tried with those solutions. …but none working.

anybody have real experience in doing this ? please share the steps

You’ve followed the steps in the WordPress article I linked to, and that didn’t solve the problem?

And if that wasn’t what you wanted, maybe you’re looking for this?

Giving WordPress Its Own Directory

I did change with MySQL part. It did not work.
Could you please specify which section you are referring… I wish to revisit it

Go to Website Admin Panel http://example.com/wp/wp-admin/
Settings > General > WordPress Address (URL)

@umairabubakkar After doing that I received …

Not Found

The requested URL /index.php was not found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.