How do I update my SSL library on git?

#1

Guys I’ve been posting this question everywhere and no one will give me a step by step solution. I’m new to git and programming and I’m not technical at all. So I don’t understand what ppl tell me to do to fix the issue, its very frustrating because google is just as complicating. The issue I’m running into is trying to clone a repository. I get this error message.

Marian@Marian-PC MINGW64 ~/Desktop/codeProjects/kaneConcrete
$ git clone https://github.com/spabsa/Kane-Concrete-Construction.git 2
Cloning into ‘Kane-Concrete-Construction’…
remote: Enumerating objects: 24, done.
remote: Counting objects: 100% (24/24), done.
remote: Compressing objects: 100% (19/19), done.
error: RPC failed; curl 56 SSL read: error:1408F10B:SSL routines:SSL3_GET_RECORD :wrong version number, errno 0
fatal: The remote end hung up unexpectedly
fatal: early EOF
fatal: unpack-objects failed

I’ve been told to do a number of things, most of which I don’t understand.

First I updated git, which didn’t do anything.

then I changed the post buffer size to

git config http.postBuffer 524288000

Then I tried cloning a different repository, and got the same issue.

I’ve also been suggested to update my ssl library, check my network connection speed, check my local proxy, change to http url for https_proxy, and change SSL to TSL.
I don’t know how to do any of this. Like I said I’m new to all of this. Can someone plz hold my hand and baby feed me the steps to the solution?

I’m using windows 7 btw.

1 Like
#2

Well, the first thing you need to do is tell us how you installed Git in the first place so that we know where to start.

#3

I downloaded it from there website at
https://git-scm.com/downloads

#4

Ok, did you recently download it or did you download it along time ago? Also, what version of Git are you using? I believe you can find out the version number by going into Control Panel and then clicking on Uninstall Program. Scroll to where you see Git and look to the far right, it should have a column called Version. I need to know so I can figure out if it’s a version problem or if it’s something else.

#5

I downloaded it a while ago and then re-downloaded it to update it as this was the first thing I tried to fix the issue.

git version 2.21.0.windows.1
Is what I’m using. It’s up to date. ppl are telling me it might be my proxy? I don’t even know what that is? or how to fix an issue like that?

#6

Ok, so I did some research and a lot of the results seems to point to raising the post buffer. Though you have already attempted that and got no where. It doesn’t look like you did it via global so try doing global.

git config --global http.postBuffer 524288000

I know that you’re getting no where, but it’s worth a try.

#7

I am using Linux Ubuntu 18.04, used the Git command and downloaded all files without any problems.

Perhaps remove the current Git installation and trying an alternative:

Other Git for Windows downloads
Git for Windows Setup
32-bit Git for Windows Setup.

64-bit Git for Windows Setup.

Git for Windows Portable ("thumbdrive edition")
32-bit Git for Windows Portable.

64-bit Git for Windows Portable.

#8

Weird problems with ssl can also occur when the system time is off by too much. Can you please check the system time seems OK? (everything up to a few minutes is fine, everything above that is not)

#9

didn’t work

#10

how would I check that? I’m new to the tech world

#11

didn’t work:(

#12

Just check the time windows is showing. You can click on it to open a clock and see the date as well.

#13

The clock on the task bar?
If so it’s showing the correct time and date

#14

How many of the six options did you try?

#15

Well I have a 64 bit OS. So it made sense to me to do the 64-bit setup. This is the one I originally downloaded and the only one I tried. Would having any other of these separate versions be functional on my desktop?

#16

I would hazard a guess and think all six programs would work and also think the 32 bit versions would be slightly slower.

Edit:
I think there could be problems running the 64 bit versions if and only if the operating system is 32 bit.

#17

32 bit didn’t work.

and the portables wouldn’t download correctly

#18

Windows is great when it is working but fraught with hidden complications when problems arise. Perhaps investigate installing Linux because it is the same operating system as Git.

I am surprised that the 32 bit is showing the same problem.

What do you mean with “wouldn’t download correctly”?

#19

the installer kept saying that it didn’t install correctly. I also used my laptop to clone the same repo and it worked, so it’s not a network issue. I also don’t want to use linux. This isn’t my computer.

#20

I don’t think it’s because of the system architectures. You can’t install 32 bit programs on a 64 bit system unless it’s specified to support 32 bit. I was going to ask you if you could uninstall it using something like CCleaner so that you get every single bit of the old files, but as you have mentioned multiple times that you aren’t tech savvy, it’s going to be more difficult to explain. Basically, what I suspect is that the older files from your early installation has hindered and is causing the problem for your recent installation. What I would do is uninstall it completely with either CCleaner or iobit uninstaller to completely uninstall and shred hindering files. This will lessen the problems you have if you were to install a newer version of any program.