How do I remove this mobile code from my Wordpress blog?

Some years ago I paid to have this theme added to my WP site (on my Bluehost account) because it was a mobile-friendly version. I would like it removed because the home page is clunky, but I don’t know how to do so. Is there a standard way that paid themes are removed? It only shows on mobile. On desktop it shows the page I want to show. (Not sure whether you need my URL.)

The theme will be using media queries to style elements differently depending on the browser’s dimensions. You can test this by resizing your desktop browser to presumably see the same effect.

There isn’t an “on/off” button to toggle this. If you want to remove the mobile view, but keep the theme looking like it does on Desktop, you’ll need to find where these styles are applied in the theme and remove them.

Not knowing how to do that, I suppose the next best thing is to simply get a new theme.

Yup.

Out of interest, you got a link to the site where this is occuring?

You can’t remove a theme from a WP site without replacing it with another. A WP site must be based on a theme.

1 Like

Yes, in my bio. It does not work if you narrow your screen. It only appears on mobile.

I will take care of this today. Wonder of it all is that this idea didn’t occur to me earlier!

If I go to Appearance, Themes, it tells me that “Twenty Ten” is active. So the themes are only being applied to the desktop version. I don’t see where the mobile themes are.

I’m not aware that WP uses different themes for desktop and mobile. Twenty Ten is an old theme - nearly 10 years old now. I don’t know if it is responsive, but what you need is a responsive theme so it works properly on whatever size screen it’s being displayed on.

Yes, I know that :slight_smile:

I looked through the directory. I see wp-content > plugins > mobile-wordpress-pack. This directory contains a lot of folders and files. I don’t know what I’m looking for. But it calls itself a plugin, so maybe that’s the way to disable it.

I went back to the dashboard, clicked on Plugins > Installed Plugins and there it was. So I clicked to deactivate it. Now it’s gone!

1 Like