How do I make localhost public?

Hello guys.

My apache settings has the following instructions:

Listen 27015
ServerName 192.168.1.22

I have also set up port forwarding.

When i try to reach the server through my wan ip + port I manage to reach it if i send the request from the same computer as the server/localhost.

But when I try to reach the page with my phone that has another network / ip it is not possible.

Do you have any idea what I might have missed?

Best regards
Neo

Most likely, your router needs to be told to forward the port to your computer.

It works on the local computer because your computer says “Oh that IP is me. Don’t go anywhere, it’s localhost.”

1 Like

I solved it all by adding “internal port” to the port forwarding settings. Previously, I only had ip and “external port” …

Can it be done this way or are there any security areas I need to think about here?

I mean, you’re opening a port on your computer to the internet. There will always be security concerns when you do that.

That said, it’ll be the only way to access the service. Not sure if anything else depends on port 27015; it’s a fairly high port number, so it wont be any critical service.

1 Like

Got it.

I have not allowed access (share) to files or folders on my computer.

Can anyone access my computer directly when the gate is open? (eg being able to “enter” and explore the file system freely from their own device. In that case, how do I prohibit access from others)

Or is it only possible for others to access information on my computer by sending requests to the server?