<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8">
    <title>How do I create a modifiable &quot;template&quot; document in javascript? - JavaScript - The SitePoint Forums</title>
    <meta name="description" content="If I have html like this: 
// more html
&amp;lt;div id=&amp;quot;myTemplate&amp;quot;&amp;gt;
	// more html
	&amp;lt;form id=&amp;quot;form&amp;quot;&amp;gt;
	&amp;lt;input type=&amp;quot;hidden&amp;quot; name=&amp;quot;your_name_here&amp;quot; value=&amp;quot;&amp;quot;&amp;gt;
    &amp;lt;/form&amp;gt;
	// more html
&amp;lt;/div&amp;gt;

// more html

I want to create a “mini&amp;hellip;">
    <meta name="generator" content="Discourse 2.6.0.beta1 - https://github.com/discourse/discourse version 09254410eabc232a664e96f6480a3b63eec4e2e0">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#ffffff">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="The SitePoint Forums Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_0fa648e5e4ead461072092da9ce2ae49fbbcd6a0.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_afc848f72167ada1fc9bd846a60abbe5238f9629.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    




<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/fb25ec51cebc2642582754450c5a992887290bec.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

<link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-00f5cdf7dfd45cba1ae2d258c3366c371c5671023250abbd964a1f16fc2c11a7.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-00f5cdf7dfd45cba1ae2d258c3366c371c5671023250abbd964a1f16fc2c11a7.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;How do I create a modifiable &quot;template&quot; document in javascript?&#39;" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046.rss" />
    <meta property="og:site_name" content="The SitePoint Forums" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046/9" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046/9" />
<meta property="og:title" content="How do I create a modifiable &quot;template&quot; document in javascript?" />
<meta name="twitter:title" content="How do I create a modifiable &quot;template&quot; document in javascript?" />
<meta property="og:description" content="Thanks for the very informative code! And especially for the way to select all form elements by name and the note about IDs. (That is a problem I would have run into immediately.) This helps a lot." />
<meta name="twitter:description" content="Thanks for the very informative code! And especially for the way to select all form elements by name and the note about IDs. (That is a problem I would have run into immediately.) This helps a lot." />
<meta property="article:published_time" content="2020-08-10T18:33:58+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/de505def0910c61bac51ad5aafe5a62e28ea5dd8.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="The SitePoint Forums" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">How do I create a modifiable &quot;template&quot; document in javascript?</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/javascript/33" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #d3a604'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>JavaScript</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Torite'><span itemprop='name'>Torite</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-08-09T01:42:30Z'>
              <time itemprop='dateModified' datetime='2020-08-09T01:58:47Z' class='post-time'>
                August 9, 2020,  1:58am
              </time>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>If I have html like this:</p>
<pre><code class="lang-auto">// more html
&lt;div id="myTemplate"&gt;
	// more html
	&lt;form id="form"&gt;
	&lt;input type="hidden" name="your_name_here" value=""&gt;
    &lt;/form&gt;
	// more html
&lt;/div&gt;

// more html
</code></pre>
<p>I want to create a “mini” document that I can use the general document functions on, like getElementById() and getElementsByName().</p>
<p>But if I use</p>
<p><code>let myClone = document.getElementById('myTemplate').cloneNode(true);</code></p>
<p>I cannot manipulate the myClone variable with functions like getElementById and getElementsByName, because I receive TypeError: myClone.getElementById is not a function</p>
<p>I especially want to select all input elements by their name (here it is “your_name_here”) and set their values in this html selection.</p>
<p>What is the proper way to do this? I want to manipulate the html and then paste it back on the page in a different spot. I will have to do this repeatedly, with different values each time.</p>
<p>Here’s a related question I had while trying to solve this myself. The function querySelector() works with myClone: myClone.querySelector(). Why does this function work but functions like getElementsByName() do not? How do I know where and what objects querySelector() works on but functions like getElementsByName() do not?</p>
        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-08-09T01:46:06Z'>
              <time itemprop='dateModified' datetime='2020-08-09T01:50:23Z' class='post-time'>
                August 9, 2020,  1:50am
              </time>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group quote-modified" data-username="Torite" data-post="1" data-topic="356046">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/t/b3f665/40.png" class="avatar"> Torite:</div>
<blockquote>
<p>let myClone = document.getElementById(‘myTemplate’);</p>
</blockquote>
</aside>
<p>That isn’t a clone of the template. Instead it’s a reference directly to the template itself.</p>
<p>To create a clone, you’ll want to use cloneNode along with the true argument, telling to to make a deep clone.:</p>
<pre><code class="lang-javascript">let myClone = document.getElementById('myTemplate').cloneNode(true);
</code></pre>
<aside class="quote no-group" data-username="Torite" data-post="1" data-topic="356046">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/t/b3f665/40.png" class="avatar"> Torite:</div>
<blockquote>
<p>What is the proper way to do this? I want to manipulate the html and then paste it back on the page in a different spot. I will have to do this repeatedly, with different values each time.</p>
</blockquote>
</aside>
<p>The following page gives good details about using JavaScript to manipulate HTML templates.</p>
<aside class="onebox allowlistedgeneric">
  <header class="source">
      <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/e/8ee5731d9f9aa0c8dbc9df8a6b5fed1440be5cb9.png" class="site-icon" width="32" height="32">
      <a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/template" target="_blank" rel="noopener">MDN Web Docs</a>
  </header>
  <article class="onebox-body">
    <img src="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84_2_500x500.png" class="thumbnail onebox-avatar" width="500" height="500" srcset="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84_2_500x500.png, https://aws1.discourse-cdn.com/sitepoint/original/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84.png 1.5x, https://aws1.discourse-cdn.com/sitepoint/original/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84.png 2x" data-small-upload="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84_2_10x10.png">

<h3><a href="https://developer.mozilla.org/en-US/docs/Web/HTML/Element/template" target="_blank" rel="noopener">: The Content Template element</a></h3>

<p>The HTML Content Template (template) element is a mechanism for holding HTML that is not to be rendered immediately when a page is loaded but may be instantiated subsequently during runtime using JavaScript.</p>


  </article>
  <div class="onebox-metadata">
    
    
  </div>
  <div style="clear: both"></div>
</aside>

        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Torite'><span itemprop='name'>Torite</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-08-09T01:58:21Z'>
              <time itemprop='dateModified' datetime='2020-08-09T01:59:41Z' class='post-time'>
                August 9, 2020,  1:59am
              </time>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Sorry, I just forgot to add that in my simple code above! I do use cloneNode() in my real code, like this:</p>
<p><code>let myClone = document.getElementById('myTemplate').cloneNode(true);</code></p>
<p>And it still does not work. Thanks for pointing that out, though. I edited it above.</p>
<p>I actually already read that link (and based my code around it) but cannot use html templates in this situation. The link also only uses querySelector on the clone, not the functions I am trying to use like getElementsByName().</p>
        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-08-09T02:14:05Z' class='post-time'>
                August 9, 2020,  2:14am
              </time>
              <meta itemprop='dateModified' content='2020-08-09T02:14:05Z'>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I think that the main reason why getElementById and getElementsByName don’t work for you is that those are restricted to working only on the document, and not on subsets of it.</p>
        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Torite'><span itemprop='name'>Torite</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-08-09T02:42:19Z' class='post-time'>
                August 9, 2020,  2:42am
              </time>
              <meta itemprop='dateModified' content='2020-08-09T02:42:19Z'>
          <span itemprop='position'>#5</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I am definitely open to achieving the same result through alternatives means, but I’d prefer something that lets me manipulate HTML using the document functions since there are so many tutorials on how to do it available. (I guess that it would be faster to manipulate a subset of the dom, rather than the whole dom, too.)</p>
<p>Can I create a document object out of existing HTML? Examples I have found seem to show only adding one element at a time.</p>
        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-08-09T04:58:24Z' class='post-time'>
                August 9, 2020,  4:58am
              </time>
              <meta itemprop='dateModified' content='2020-08-09T04:58:24Z'>
          <span itemprop='position'>#6</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="Torite" data-post="5" data-topic="356046">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/t/b3f665/40.png" class="avatar"> Torite:</div>
<blockquote>
<p>Can I create a document object out of existing HTML? Examples I have found seem to show only adding one element at a time.</p>
</blockquote>
</aside>
<p>Sorry no. There is only one document element.</p>
        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Torite'><span itemprop='name'>Torite</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-08-09T17:56:56Z' class='post-time'>
                August 9, 2020,  5:56pm
              </time>
              <meta itemprop='dateModified' content='2020-08-09T17:56:56Z'>
          <span itemprop='position'>#7</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I guess that I need to make this template in some other way then. Can anyone suggest good ways to make a mini template, and then also show how to select all form inputs by name and then set their values within the template?</p>
        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/m3g4p0p'><span itemprop='name'>m3g4p0p</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-08-10T08:34:51Z'>
              <time itemprop='dateModified' datetime='2020-08-10T08:36:52Z' class='post-time'>
                August 10, 2020,  8:36am
              </time>
          <span itemprop='position'>#8</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi <a class="mention" href="/community/u/torite">@Torite</a>, you can still get elements by name using <code>querySelector()</code>… e.g.</p>
<pre><code class="lang-html">&lt;template id="my-template"&gt;
  &lt;form&gt;
    &lt;input type="hidden" name="timestamp"&gt;
  &lt;/form&gt;
&lt;/template&gt;
</code></pre>
<pre><code class="lang-javascript">const template = document.getElementById('my-template')
const content = template.content.cloneNode(true)

content.querySelector('[name="timestamp"]').value = Date.now()
document.body.appendChild(content)
</code></pre>
<p>Or using the form’s <a href="https://developer.mozilla.org/en-US/docs/Web/API/HTMLFormElement/elements"><code>elements</code></a> collection:</p>
<pre><code class="lang-javascript">const template = document.getElementById('my-template')
const content = template.content.cloneNode(true)
const form = content.querySelector('form')

form.elements.namedItem('timestamp').value = Date.now()
document.body.appendChild(content)
</code></pre>
<p>BTW be careful with IDs inside templates; if you want to render its content more than once, be sure to append an increment ID or something to avoid duplicate IDs in your document… for instance, if you need IDs for input / label relations:</p>
<pre><code class="lang-html">&lt;template id="my-template"&gt;
  &lt;form&gt;
    &lt;input type="hidden" name="timestamp"&gt;
    &lt;label for="username"&gt;Username&lt;/label&gt;
    &lt;input type="text" id="username" name="username"&gt;
  &lt;/form&gt;
&lt;/template&gt;
</code></pre>
<pre><code class="lang-javascript">;['John', 'Paul', 'Ringo', 'George'].forEach((name, index) =&gt; {
  const content = template.content.cloneNode(true)
  const form = content.querySelector('form')

  form.elements.namedItem('timestamp').value = Date.now()
  form.elements.namedItem('username').value = name

  content.querySelectorAll('[id]').forEach(element =&gt; {
    const { id } = element
    element.id = id + '-' + index

    content.querySelectorAll(`[for="${id}"]`).forEach(label =&gt; {
      label.setAttribute('for', element.id)
    })
  })

  document.body.append(content)
})
</code></pre>
        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="3" />
           <span class='post-likes'>3 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Torite'><span itemprop='name'>Torite</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/how-do-i-create-a-modifiable-template-document-in-javascript/356046">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-08-10T18:33:58Z' class='post-time'>
                August 10, 2020,  6:33pm
              </time>
              <meta itemprop='dateModified' content='2020-08-10T18:33:58Z'>
          <span itemprop='position'>#9</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Thanks for the very informative code! And especially for the way to select all form elements by name and the note about IDs. (That is a problem I would have run into immediately.) This helps a lot.</p>
        </div>

        <meta itemprop='headline' content='How do I create a modifiable &quot;template&quot; document in javascript?'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <div class="proper-ad-unit ad-sticky">
   <div id="proper-ad-sitepoint_main_1">
       
    </div>
</div>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/b7c2dddc040843c0c556142972c499dd3d93275f.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
