How can I remove this credential suggestions in Chrome?

Hi,

looks like Chrome has added a new feature in one of the last versions. This feature is far too intelligent (or even not).

I have an input field which I use for a date picker. If I now click on the input field, normally the date picker opens up. But since the last Chrom update also the credentials suggestions are popping up:

InputProblem

I have already tried autocomplete= “off”

but it doesn’t help.

At this point I want suggestions from you, how to get rid of the suggestions in Chrome :slight_smile:

(or more specifically, it’s the auto-fill, not the offer to save, but you get the point)

Or why not change the input type to date since it’s a date field?

<input name="datePicker" type="date" class="calendarDatePicker hasDatePicker" id="datePicker">

@m_hutley

Sorry i do not get what this site should help me.

@DaveMaxwell

This could help in this case, but I have some other „real“ input fields on my application which have the same problem and there I can’t change the type.

The point is that Chrome’s password/form autofiller is dumb and prompts you on pretty much every text field. The solution being to tell it to go away. :stuck_out_tongue:

Could be a problem to tell GE that they should not use their recommended browser :smiley:

Do they mandate you use the password manager feature?

What should it help when I disable this feature in my browser, while thousands of my app users have it on per default?

Because doing so in your browser is a decision that you’re making for yourself, rather than stripping a user’s ability to use the feature if they desire to?

This discussion drifts away…

Has anyone an idea how I can fix this?

Not sure its something to be “fixed”, but… Chrome doesnt respect autocomplete=“off”. They’ve been told, they’ve maintained their stance since 2015 or earlier that they will not implement autocomplete=“off” in Chromium.

I’ve seen (old) suggestions that giving the autocomplete attribute a nonsensical value might work, like autocomplete=“do-not-autocomplete-you-stupid-browser”, which apparently confuses the browser into ignoring it for completion terms, but i’m… not sure that’ll work against the password manager version of the feature.

Finally I found a solution which is good for me as I do not use forms.

Chrome is not offering autocomplete for items in forms with less than 3 items. So I wrap all my input fields with

form action = “javacript:void(0)”

2 Likes

I find that odd, as most forms that chrome WOULD be autocompleting would be a user/pass combo… but glad you found something that works.