<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8">
    <title>Help with Fade Out or Dissolve text, in CSS animation - HTML &amp; CSS - SitePoint Forums | Web Development &amp; Design Community</title>
    <meta name="description" content="This code I’m using displays successfully sliding out text horizontally across the page. However, I’d like it to only display temporarily, I’ve searched css amination and tried several things without success. Sliding tex&amp;hellip;">
    <meta name="generator" content="Discourse 2.6.0.beta2 - https://github.com/discourse/discourse version 28cd1aaf8e1f13c7342d53259792d3489a061f5b">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#ffffff">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="SitePoint Forums | Web Development &amp; Design Community Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_0badb6251b5e0fe1e09fde8cf35dd15c0e9f499a.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_f9699c38c43669b226af0abd2024432edb0c886a.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    




<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/fb25ec51cebc2642582754450c5a992887290bec.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

<link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Help with Fade Out or Dissolve text, in CSS animation&#39;" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436.rss" />
    <meta property="og:site_name" content="SitePoint Forums | Web Development &amp; Design Community" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436/8" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436/8" />
<meta property="og:title" content="Help with Fade Out or Dissolve text, in CSS animation" />
<meta name="twitter:title" content="Help with Fade Out or Dissolve text, in CSS animation" />
<meta property="og:description" content="This topic was automatically closed 91 days after the last reply. New replies are no longer allowed." />
<meta name="twitter:description" content="This topic was automatically closed 91 days after the last reply. New replies are no longer allowed." />
<meta property="article:published_time" content="2020-09-28T18:08:50+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/6957e2fcfacbacc6fd64ad78da0cb9deeae37bc4.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="SitePoint Forums | Web Development &amp; Design Community" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">Help with Fade Out or Dissolve text, in CSS animation</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/html-css/25" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #ba5401'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>HTML &amp; CSS</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ChrisjChrisj'><span itemprop='name'>ChrisjChrisj</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-26T21:56:16Z' class='post-time'>
                June 26, 2020,  9:56pm
              </time>
              <meta itemprop='dateModified' content='2020-06-26T21:56:16Z'>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>This code I’m using displays successfully sliding out text horizontally across the page. However, I’d like it to only display temporarily, I’ve searched css amination and tried several things without success. Sliding text back out would be one solution, but I’m not adding the code correctly apparently. Ideally, I’d actually like something more interesting than simply sliding back, like fading out or dissolving the text, etc. How can I add slide back, fade or some type of dissolve text to this code. I’m open to suggestion. Here’s the current working code:</p>
<pre><code class="lang-auto">.animation-box4 {
  min-height: 4.5rem;
  margin: 15% auto 0;
  display: flex;
  align-items: center;
  width: 80%;
  overflow: hidden;
}

.message {
  font-size: 30px;
  display: inline-block;
  font-weight: 900;
  font-family: sans-serif;
}

.sliding-text-1,
.sliding-text-2,
.sliding-text-3 {
animation-name: slide;
animation-duration: 1s;
animation-timing-function: ease-out;
animation-iteration-count: 1;
  animation-fill-mode: forwards;
  opacity: 0;
}

.sliding-text-1 {
  animation-delay: 5s;
  color: #ff00ff;
}

.sliding-text-2 {
animation-delay: 6.5s;
color: #ccc;
}

.sliding-text-3 {
  animation-delay:8s;
  color: #fff;
}

u/keyframes slide {
  from {
    transform: translateX(200px);
  }
  to {
    transform: translateX(0px);
    opacity: 1;
  }
  }
</code></pre>
<p>Any guidance or examples are welcomed.<br>
Thanks for all previous help.</p>
        </div>

        <meta itemprop='headline' content='Help with Fade Out or Dissolve text, in CSS animation'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/PaulOB'><span itemprop='name'>PaulOB</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-27T12:01:04Z' class='post-time'>
                June 27, 2020, 12:01pm
              </time>
              <meta itemprop='dateModified' content='2020-06-27T12:01:04Z'>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>You didn’t post any html for us to test with but If I understand your question then you just amend your keyframes accordingly.</p>
<p>At 50% you could have the element where you want it and then from 50% to 100% you can bring it back or fade it out again as required.</p>
<p>You don’t have to have just one action in a keyframe. You could for example travel an element to the right and then send it downwards and then back again and up to make it travel a square.</p>
<p>It’s not possible to dissolve an element in CSS but you can blur it and fade it out.</p>
<p>Without a demo of the animation you have then its hard for me to give a specific answer.</p>
<p>Here’s a simple demo anyway than you can deconstruct <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"><br>
<iframe id="cp_embed_RwrZMqQ" src="https://codepen.io/paulobrien/embed/preview/RwrZMqQ?height=300&amp;slug-hash=RwrZMqQ&amp;default-tabs=css,result&amp;host=https://codepen.io" title="Keyframe animation" scrolling="no" frameborder="0" height="260" class="cp_embed_iframe" width="695" seamless="seamless" sandbox="allow-same-origin allow-scripts allow-forms allow-popups allow-popups-to-escape-sandbox allow-presentation"></iframe></p>
        </div>

        <meta itemprop='headline' content='Help with Fade Out or Dissolve text, in CSS animation'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ChrisjChrisj'><span itemprop='name'>ChrisjChrisj</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-06-28T19:24:00Z'>
              <time itemprop='dateModified' datetime='2020-06-28T19:24:12Z' class='post-time'>
                June 28, 2020,  7:24pm
              </time>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Thanks again for your kind help.<br>
I’ve experimented with you code and researched online some more regardind css animation, but am not clear yet on how your keyframes % example works with my “to” and “from” and (200px) code.</p>
<p>Any additional input in welcomed.</p>
        </div>

        <meta itemprop='headline' content='Help with Fade Out or Dissolve text, in CSS animation'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/PaulOB'><span itemprop='name'>PaulOB</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-28T21:54:57Z' class='post-time'>
                June 28, 2020,  9:54pm
              </time>
              <meta itemprop='dateModified' content='2020-06-28T21:54:57Z'>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>What is it you don’t understand?</p>
<p>If you want to slide your text 200px and back 200px and then fade out then the example I gave should show all you need to know.</p>
<p>Just slide your text in to where you want. That would be your start 0% of the key frame. (You can’t use to and from because you want a few actions not just 2.)</p>
<p>Next slide it back at say 30 - 50%. Then from 50% to 100% fade/ blur the element out to finish. All those effects are already baked in the demo I gave so just remove the bits you don’t want.</p>
<p>Have a go yourself and if you get stuck then post your code and it will let me know where you are going wrong.</p>
        </div>

        <meta itemprop='headline' content='Help with Fade Out or Dissolve text, in CSS animation'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/ChrisjChrisj'><span itemprop='name'>ChrisjChrisj</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-06-29T00:06:09Z'>
              <time itemprop='dateModified' datetime='2020-06-29T00:07:24Z' class='post-time'>
                June 29, 2020, 12:07am
              </time>
          <span itemprop='position'>#5</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Thank you again. I appreciate the further clarification.<br>
The code now shows:</p>
<pre><code class="lang-auto">@keyframes slide {
  0% {
    transform: translateX(200px);
  }
  50% {
    transform: translateX(0px);
    opacity: 1;
  }
    60% {
      transform: translateX(0px);
      opacity: 1;
  }
    70% {
      transform: translateX(0px);
      opacity: 1;
  }
    80% {
      transform: translateX(0px);
      opacity: 1;
  }
    90% {
      transform: translateX(0px);
      opacity: .5;
  }

  100% {
    transform: translate(0px);
    opacity: 0;
  }
}
</code></pre>
<p>along with this:</p>
<p><code>animation-duration: 10s;</code></p>
<p>which slides out the text and then fades it out successfully. Thanks.</p>
<p>I have another question, so tell me if it should be a new posting.<br>
I liked how fast the text slide out when it was:<br>
<code>animation-duration: 1s</code><br>
using the ‘to’ and 'from" that was fine, because it slide out fast and stayed displayed.<br>
But, of course if I keep:<br>
<code>animation-duration: 1s</code><br>
with the new keyframes, it slides out fast and then disappers too quickly.<br>
I looked/searched for how to get the text to linger for a while and then disappear, but they only thing I could find was to lengthen the duration, which makes it slide out too slow.<br>
How can the text slide out as fast as it did, linger(pause) and then fade away after x seconds?</p>
<p>I look forward to your reply/feedback … much thanks again</p>
        </div>

        <meta itemprop='headline' content='Help with Fade Out or Dissolve text, in CSS animation'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="2" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/PaulOB'><span itemprop='name'>PaulOB</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T08:15:56Z' class='post-time'>
                June 29, 2020,  8:15am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T08:15:56Z'>
          <span itemprop='position'>#6</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="ChrisjChrisj" data-post="5" data-topic="354436">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/c/e9a140/40.png" class="avatar"> ChrisjChrisj:</div>
<blockquote>
<p>I liked how fast the text slide out when it was:<br>
<code>animation-duration: 1s</code><br>
using the ‘to’ and 'from" that was fine, because it slide out fast and stayed displayed.<br>
But, of course if I keep:<br>
<code>animation-duration: 1s</code><br>
with the new keyframes, it slides out fast and then disappers too quickly.</p>
</blockquote>
</aside>
<p>Ok you have to use the time available during the keyframe duration to do the things you want.</p>
<p>If you want it to slide for 1s then stay still for say 2s then slide back for 1s and then fade out for 2s after its stopped then the animation duration is 6s.</p>
<p>Now you just divide  6s by 100% to get the percentage required for each second of the keyframe.</p>
<p>Therefore first work out how long you want each part of the animation to take and then you can use math to work out the key frame percentage for each.</p>
<p>If for example you had 5 equal actions over 10 seconds  then they’d need 20% each for the key frames.</p>
<p>0% {start position }<br>
20%{first stop position - has taken 2s}<br>
40%{same rule as before so nothing happens for 2s}<br>
41%{start another action}<br>
60%{stop another action}<br>
80%{same rule as before so we do nothing for 2s}<br>
81%{start final effect}<br>
100%{finish last effect}</p>
<p>Is that any clearer? <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
        </div>

        <meta itemprop='headline' content='Help with Fade Out or Dissolve text, in CSS animation'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/PaulOB'><span itemprop='name'>PaulOB</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T11:08:44Z' class='post-time'>
                June 29, 2020, 11:08am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T11:08:44Z'>
          <span itemprop='position'>#7</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="ChrisjChrisj" data-post="5" data-topic="354436">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/c/e9a140/40.png" class="avatar"> ChrisjChrisj:</div>
<blockquote>
<p>using the ‘to’ and 'from" that was fine,</p>
</blockquote>
</aside>
<p>‘to’ and ‘from’ equates to 0% and 100%.</p>
<p>e.g. These are the same:</p>
<pre><code class="lang-auto">@keyframes slide {
     0% {
         transform: translateX(200px);
    }
     100%{
         transform: translateX(0px);
    }
}
</code></pre>
<p>Is the same as <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
<pre><code class="lang-auto">@keyframes slide {
     from {
         transform: translateX(200px);
    }
     to {
         transform: translateX(0px);
    }
}
</code></pre>
<p>The difference being is that from and to are just the start and finish points. If you want intermediate steps then you need to use percentages as shown previously.</p>
<p>Maybe a simpler example will help <img src="https://sjc5.discourse-cdn.com/sitepoint/community/images/emoji/apple/slight_smile.png?v=9" title=":slight_smile:" class="emoji" alt=":slight_smile:"></p>
<p><iframe id="cp_embed_wvMreXX" src="https://codepen.io/paulobrien/embed/preview/wvMreXX?height=300&amp;slug-hash=wvMreXX&amp;default-tabs=css,result&amp;host=https://codepen.io" title="Slide and fade" scrolling="no" frameborder="0" height="260" class="cp_embed_iframe" width="695" seamless="seamless" sandbox="allow-same-origin allow-scripts allow-forms allow-popups allow-popups-to-escape-sandbox allow-presentation"></iframe></p>
        </div>

        <meta itemprop='headline' content='Help with Fade Out or Dissolve text, in CSS animation'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/system'><span itemprop='name'>system</span></a>
            
              closed 
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/help-with-fade-out-or-dissolve-text-in-css-animation/354436">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-09-28T18:08:50Z' class='post-time'>
                September 28, 2020,  6:08pm
              </time>
              <meta itemprop='dateModified' content='2020-09-28T18:08:50Z'>
          <span itemprop='position'>#8</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.</p>
        </div>

        <meta itemprop='headline' content='Help with Fade Out or Dissolve text, in CSS animation'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <!--//
<div class="proper-ad-unit ad-sticky">
    <div id="proper-ad-sitepoint_main_1">
        <script> 
            // propertag && propertag.cmd.push(function() { proper_display('sitepoint_main_1'); });
        </script>
    </div>
</div>
//-->
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/0225110c0cade405081c48cfc831f094dcd8909d.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
