Help I can't get Localhost of WAMP to show on browser

For some funny reason beyond my understanding I can’t get my WAMP to function properly. I have been using WAMP for several months, one day I suddenly realized that I couldn’t get localhost to open on my web browser. I tried it on Firefox and Chrome nothing worked.

I uninstalled WAMP, even deleted the WAMP folder from c: and reinstalled yet I still have the same problem.

When I start WAMP, the icon shows white which indicates that all the services should function but when I click on localhost nothing comes up. I even stopped Skype on my PC from functioning just incase but still Localhost wouldn’t come up on my webbrowser. Please can anyone help, I am really confused here. Thank you

Check for any app that is trying to use the same port

Hello spacephoenix, thanks for coming to my aid but please how do i check on any app that is using the same port

sam,

First, Welcome to SitePoint’s Apache forum!

Second, SP has a good point and I’m not sufficiently up on the code to have WinDoze check the ports (I just checked netstat via Start | Run | and entering netstat). On the other hand, the likely culprit with regard to preventing Apache from starting is IIS. Use Start | Run | services.msc and look for IIS in the right pane. If it’s running, it’s using port 80. I’ve stopped my IIS and, using properties, told it to NEVER start automatically (which it does by default on WinDoze start) BEFORE I installed Apache. That resolved any potential problem with IIS.

It’s likely, in your case, that a M$ upgrade reinstalled IIS to restart automatically so go check and kill that POS.

Regards,

DK

Hello dklyn, thanks for your help. Unfortunately when I followed your instruction I didn’t see any IIS

samuel,

Have you made any configuration changes lately? It’s likely that one of those contain a formatting error in a modified directive.

Because WAMP et al (canned programs) are beasties unto themselves, I’d have to say to either check their forum for similar problems or merely UNinstall and reinstall.

Of course, my “standard” recommendation is to follow Kevin Yank’s process in the FREE chapter of his book for installing the daemons the way they’re supposed to be installed rather than using WAMP et al canned (modified) versions.

Regards,

DK

Thank you dklynn please how do I get Kevin Yank’s book and please could you direct me to the wamp forum you mentioned. Thanks once again

Kevin’s book is here. The WAMP forums are [URL=“http://www.wampserver.com/phorum/list.php?2”]here. Around the time that the problem started did you have any updates get applied to your firewall software or to Windows?

My computer is on automatic update from Microsoft. I think thats where the problem came from. My computer downloaded an application from Microsoft and I installed it without knowing it would cause this problem. I have even done a system restore to a former date but the problem still persists. I am trying to find out how I can find out the ports on windows xp and disable the one sharing with wamp. Thank you all help is greatly appreciated

What app was installed by windows?

Sammy,

“On Windows, TCP/IP port assignments are stored in the C:\WINDOWS\SYSTEM32\DRIVERS\ETC\SERVICES file.”

Use a text editor (NotePad if you don’t have EditPad Lite) to read what the app is that’s sitting on port 80.

Regards,

DK

I too have the same problem. I applied updates and now my Wamp won’t work. I am running Windows 7 32. I have changed the port. I disabled the UAC and stopped IIS. I even changed the hosts file to delete the 127.0.0.1. All to no avail. I still get this message when I run localhost: Unable to connect
Firefox can’t establish a connection to the server at localhost.

       *   The site could be temporarily unavailable or too busy. Try again in a few
      moments.

*   If you are unable to load any pages, check your computer's network
      connection.

*   If your computer or network is protected by a firewall or proxy, make sure
      that Firefox is permitted to access the Web.

Do you have a line in your hosts file which looks like:

::1 localhost

if so try adding a # at the start. You might need to reboot the computer for it to take affect

taz,

Changing the port isn’t trivial - I believe that you must REINSTALL Apache on the new port for it to work. Moreover, stopping IIS is not sufficient as it will RESTART automatically (when WinDoze restarts). Finally, wiping out 127.0.0.1 in your hosts file SHOULD kill localhost as a VirtualHost.

IMHO, get the free chapters of Kevin Yank’s book and install by the numbers to get it right.

Regards,

DK