Header doubled height in Firefox

Hey…I’ve got a sort of strange issue that seems to be only be visible in Firefox. On my website, I have created a header that has navigation in it. Seems simple enough, except that the header is doubled in height in Firefox only. It looks as it should in Chrome, Safari, and IE.

One catch that sort of complicates things. The “contact” link triggers a script that lowers a form into view. So the margin is set at -250, then the link toggles it down/up 250.

So any ideas on why it seems to be set 30 pixels too far down in Firefox only?

Thanks all!

Hi, you’ll need to provide a link to get a fix.

Wow…I’m an idiot. What, you can’t read my mind?

Thanks!

Looks the same to me in all browsers unless I’m looking at the wrong thing.:slight_smile:

Where exactly is the extra space?

I can see that #header is only 30px high yet the navcontainer inside is much taller than that. However as you have hidden the overflow the extra height won;t show anyway.

I guess perhaps my Firefox or computer or something are freaking out…because this is the second time I’ve had problems with something that I haven’t been able to show others. It looks fine now…crazy internet.

Thanks for checking on it anyhow. Appreciate it.

Maybe a cache issue or something:) You just can’t trust computers .

I ended up reinstalling Firefox…and everything looked as it should. I had cleared the cache, and that didn’t seem to help…but perhaps my install didn’t work as it should.

Anyhow…all is well at the moment. Thanks for taking a look for me.

Sorry to bump a resolved thread…but I figured out what my problem was, and thought I’d share in case someone else had similar issues.

It turns out my issue was related to the newest version of Wordpress (3.1) installed on my domain. The newest version includes an admin bar that can be set to be visible (when logged in) while viewing the site or in the dashboard. I found this setting and set it to only in the dashboard, and voila! It fixed my issue. I’m not sure why the admin bar wasn’t visible…but it was taking up that space.

Problem solved. Thanks for your help guys.

Thanks for letting us know what the problem was - It could help others :slight_smile: