Had to reinstall xampp - cant start apache

Was getting a controluser error. re installed xampp on win7 using the latest installer.
now i can’t start apache. I can’t find where to change the port. and have only one old file in the older folder i renamed from xampp to “asdf”>“mysqul” “bin” mysqld.exe that I can’t remove. says it is open & in use but I closed everything restrted the pc and checked control manager.
Could I get some advice on how to solve this please?

Do you have skype installed?

The reason I ask, it uses port 443 (if I recall correctly) and that may be blocking your apache from starting. You can change it somewhere in the settings of skype to use a different port, but I don’t quite remember where that setting is.

cp it looks like i have it. but it is not installed.

k great.
tried a system restore & now went from the blue screen of near death to start up repair…this blows!

I had a few problems getting XAMPP running on Windows 7. If my memory serves, I had to right-click on the menu item or on the control panel file and choose to “run as administrator”. Then I think I had to go into my anti-virus/firewall software and allow it to communicate. After that it worked fine.

k it was kinda hairy but my laptop is up & about again (even got to see the breaking bad finale.great!) now getting back to check out xampp. i got a slightly diff ui. not sure if it is because it is the newer version or issues?
Does anyone else have this set up, w/all those question marks? Just created a database & so far no error msgs.

ok awesome. looks like xampp installed ok both apache & mysql are ok.
Also installed wp again for local testing.
but as you can see in the image i get the red exclamation marks & the message
“Your configuration file contains settings (root with no password) that correspond to the default MySQL privileged account. Your MySQL server is running with this default, is open to intrusion, and you really should fix this security hole by setting a password for user ‘root’.”
where is that configuration file???

Are all you tables of all your databases intact?

Has each web app’s database user been recreated (each limited to just that own app’s database)?

Have you created a new “super-user” for doing general work on the server (across all databases), which should be used instead of root?

Hello Space:
As for one & two, actually din’t worry about all the old databases. they were just test db and i was ok removing all of them. I was more worried that something was wrong & i would not be able to use or create new dbs

Using root as a super user for now. didn’t think it would be necessary to add a new one. Did on the previous install.

But as for my previous messages. are the exclamation marks just part of the new UI & not a concern.
For the password warning. Not sure if they are referring to a file or the setting for user’s privileges.

thx all

If you open the control panel for xampp/wamp, you should see a button that takes you to the config for phpmyadmin under the Config button for Apache.
There are fields in there for username and passwords.

To update the root username, I had to do the following:

  1. Update the phpMyAdmin to use an auth_type of ‘cookie’ instead of config.

Login to phpMyAdmin using root and no password
Click on the Change Password
Enter your new password for root
Save it

It should log you out if you try to go anywhere else. Login using your new password. The config message should have disappeared now.