Grub just hangs

Okay, so I’m in a weird predicament (I think), as I just was attempting to perform an update to the packages I have installed and it attempted to update grub, but it just sits there doing nothing… (been sitting on the below for a few hours now)

Setting up grub-efi-amd64 (1.99-27+deb7u2) ...

I have no idea how to get past this and I’m afraid to reboot as I feel it may cause the system to not boot up at all since grub isn’t updating properly.

I have an AMD64 system running Debian Wheezy with the main drive running on a SSD and it is using UEFI for booting. Can anyone help me get through this? I’m not the most proficient linux user especially when I run into problems such as this that leave me clueless.

I’m comfortable running commands and providing more information as needed. So to start out, what is it that you need from me so I can hopefully get this updating smoothly.

Things I have tried:

  1. I killed dpkg,
  2. cleaned the dat files in /var/cache/debconf/
  3. uninstalled all packages related to grub
  4. Tried to reinstall grub related packages including the efi packages

Which brings me to where I am now…

Sorry, can’t really help - when things like this happen to me, I promptly run screaming to the Ubuntu forums. :o

Where I did find this:


I don’t know if that’s the same issue or not (I know this isn’t Ubuntu), but something you said the other day led me to believe you’re using KDE desktop, so it just might be related.

I didn’t run into either of those during my searches, but I believe them to be different. I’ve got a system that originally properly installed grub with efi, but after this update, it is failing to update grub accordingly (even after purging grub from the system, it fails to properly re-install it). So I’m in a spot that I’m fairly certain I won’t be able to reboot unless I can get it to install.

I’m starting to think it may be due to the devices I have mounted, and it may be scanning those devices for bootable images. I have roughly 10 TB of space mounted, so the answer may lie in unmounting those devices and then attempting the install… but that is just a guess.

I’m afraid I have nothing more to offer, apart from sympathy. :slight_smile: I’ve had several GRUB issues in the past, so I understand the feeling. Fortunately for me, I’ve always found somebody willing to guide me through step-by-step solutions. (Oddly enough, most of my GRUB problems seem to have involved GRUB very wisely refusing to boot Windows… :shifty:)

Yeah, another part that isn’t anywhere on my system :slight_smile: All I have is the one operating system, so it shouldn’t be too complicated, but then again, this is the first time I’ve used linux on a SSD and using UEFI, so I have no idea how much that complicates the process… :frowning:

I’ve posted my question in the Debian forums too, but I’m getting a bit restless that I really can’t reboot this machine until I get this fixed, otherwise, I’m dead in the water. Oh the joys of linux, when things go wrong, they really really go wrong! :lol:

I decided on a SSD for my new laptop (and it’s disconcertingly quiet ;)), but I don’t know a thing about UEFI, I’m afraid.

Indeed. :slight_smile:

I’ve only experienced kernel panic once, but I’ve experienced user panic on several occasions. :lol:

Off Topic:

I’d just about decided to spend this afternoon doing a fresh install of Ubuntu Gnome 14.04 on this machine, rather than upgrading to “standard” Ubuntu 14.04 - but suddenly I seem to be having second thoughts…:shifty:

Yes, I love my SSD. Boot time is fast too (when you know it can boot).

I’ve run into several kernel panics but that was years ago! When I had to customize my kernel to run my nvidia graphics card. Linux has come a LONG way from then and since it came all that way, I’ve forgotten how to do most of that.

As an aside, I did eventually unmount all of my non-essential drives and try and install grub again, it still hangs :frowning:

Certainly is. :slight_smile: Granted, this machine is three years older and has half the RAM, but if I switch both on at the same time, the laptop’s booted by the time this one has reached the boot menu.

Yep - mine was five years ago. (Jaunty Jackalope - I’ll never forget it. :()

That’s the problem, isn’t it? When you don’t use stuff for a while you forget it. (At least, I know I do. :() Fortunately, in my case, I know where to find the instructions from the last time I was talked through a crisis, in case it ever happens again. :lol:


I think that was the version that stopped me from ever using Ubuntu again (or its KDE variant Kubuntu). I ran into nothing but issues throughout that version with every upgrade they sent down. I went back to Debian and basked in the stability (until this week…)

I think I had Jaunty for a week before I decided enough was enough and went back to Intrepid. I’ve had no real issues with any version of Ubuntu before or since but Jaunty (for me) was an absolute nightmare. :unhappy:

I’ve never really looked into other Linux distros, mainly because Running Bear is very happy using Ubuntu, and I’m happy he’s happy. :smiley: When we ran Windows, he was terrified of it and I was forever having to help him out with one thing or another. From the day we first tried Ubuntu he seemed to (mostly) cope by himself, and I’m not about to rock the boat. :lol:

I have recently started using Linux, had a Ubuntu drive fail and decided to give LinuxMint a try. So far impressed and also delighted.

Phew! I wasn’t the only one.

That’s understandable. Gnome is Gnome on all distros, it is just some distros become more stable on the off years of other distros. So I started with Debian in college, it became unstable about the end of college and I switched to Kubuntu (as it was Debian based), that was stable until Jaunty came out and I switched back to Debian because it was deemed stable again. Fun times.

And I hope it continues to delight you and impress you even during times it misbehaves!

So it seems I’m not patient enough… :frowning: After letting the dpkg congifuration for grub-efi-amd64 to run for over 48 hours, it finally finished! When I performed the next set of updates, it ran that post finalization configuration again and it finished instantly… go figure.

Good grief. :eek:

(And I still haven’t plucked up the courage to start a new install here…:shifty:)

Yeah, I still think it has to do with the drives I have connected/mounted, as part of the output was a timeout error, but who knows. I’ve posted the data related to it on a linux specific forum hoping to get some insight as to why that may occur. They’ve been helpful up to this point, so I bet they’ll give me a good idea as to what may have caused this to run for so long.