Google Map not working on Site

Hi Ive create a taxi site which has google maps at the bottom of it. If I were to just go straight to the taxi website http://www.lctours.co.uk/ then the map will work. However if I went to the taxi site through my own personal site http://gbeckett.com/work and click the taxi link and the google maps stops working.

Why is this happening and how can I fix it?

Any help would be much appreciated.

The map doesn’t load for me by either route.

Thats weird because it shows for me

I see the map for a brief flash, then it’s replaced by that error message.

same for me. brief flash then it is gone. Page seems to continue loading though so i am assuming it has got itself into a loop and the JS is having issues.

Thanks for the replies.I wonder why it works on my computer though?

perhaps it is loading a piece of JS in a particular order on your machine or not loading a piece of JS that is causing the problem.

I had a page and was loading JS using Async so it would load the scripts in any order. this caused problems as for some reason some of my scripts needed to be loaded first. Sometimes it would work and sometimes it wouldn’t depending on the order the scripts loaded. Might be worth checking. Just a thought.

The link to jquery does not exist.

http://www.lctours.co.uk/js/jquery-1.9.1.min.js

You probably had a cached version or something but you need to make sure the jquery file is where you say it is.

1 Like

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.