Getting error messages when importing databases

I have tried six times with two different sites to import a MySQL databse using phpmyadmin.

im using various wordpress templates i created for multiple sites (a client has 3 sites that we want to have the same look, just different content or i use the same template to create multiple sites with similar layouts). Ive found in the past that the easiest way to do this is not only to copy the theme files but import the MySQL database as well - and make changes as necessary.

so what i do is i export the original database, open the file in dreamweaver of textwrangler or something, run a find/replace on the urls (find: | replace:
i have done this multiple times without incident.

Now suddenly i am getting errors like this:

or previously it was telling me that there something was duplicated and could not be implemented - i dont remember the exact error, i did not get a screenshot of that one.

the strange thing is i just tried that one again (the one i did not have the screenshot for) and it worked perfectly, just as it has so many times before.

now the one i have the screenshot for, that was exported from godaddy, and i attempted to import it to a hosting - but as far as i know (i know almost nothing about SQL) that shouldnt matter.

anyone understand my babble here? anyone have an idea of why im getting these errors?

if you look through the files you’ll likely see some lines near the beginning that specify the user that created the tables. you can just remove those lines. then they should load fine.

The database information_schema is an internal (system) database. It looks like you took a full database backup and are attempting to restore it. I would suggest backing up one database and restore that single database.

ok here is the error message im getting:

how can i get around this?

Drop the existing table and then import it. Next time have your backup include the DROP IF EXISTS option.

I must be missing something bc i dropped this section:

-- --------------------------------------------------------

-- Table structure for table `wp_commentmeta`

CREATE TABLE `wp_commentmeta` (
  `meta_id` bigint(20) unsigned NOT NULL auto_increment,
  `comment_id` bigint(20) unsigned NOT NULL default '0',
  `meta_key` varchar(255) default NULL,
  `meta_value` longtext,
  PRIMARY KEY  (`meta_id`),
  KEY `comment_id` (`comment_id`),
  KEY `meta_key` (`meta_key`)

-- Dumping data for table `wp_commentmeta`

-- --------------------------------------------------------

and i go the same error but for wp_comments

so then i tried dropping that section as well but i got an error for something else.

Sorry, I meant for you to drop the tables that exist on the new Database you are importing to (assuming they have no data in them at this point in time). Then you should be able to import your backup successfully.

The problem is, the tables already exist in your new database, and the script you are trying to restore isn’t accounting for that situation.