<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8">
    <title>Getting div content in realtime using jquery - JavaScript - SitePoint Forums | Web Development &amp; Design Community</title>
    <meta name="description" content="Life savers, 
please i need help in getting contents from a div into another div in real time and also how to get values from sessions and show it in another div in real time. 
I have a div #messageLog as id and it gets &amp;hellip;">
    <meta name="generator" content="Discourse 2.6.0.beta3 - https://github.com/discourse/discourse version 5157e3b6e3c0253314be428f98b9f5f65bcb361e">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#ffffff">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="SitePoint Forums | Web Development &amp; Design Community Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_360c3e1414450d758a9d56968e311939f55c0612.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_2168a260ad174b1357c2e57cd69633e398995b64.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    




<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/fb25ec51cebc2642582754450c5a992887290bec.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

<link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-706f1d28f0a97f67a47515c96189277240ec4940d968955042066d7873fd1fe8.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Getting div content in realtime using jquery&#39;" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984.rss" />
    <meta property="og:site_name" content="SitePoint Forums | Web Development &amp; Design Community" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984/11" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984/11" />
<meta property="og:title" content="Getting div content in realtime using jquery" />
<meta name="twitter:title" content="Getting div content in realtime using jquery" />
<meta property="og:description" content="Not one I’m immediately aware of, but there’s always the search function. :-)" />
<meta name="twitter:description" content="Not one I’m immediately aware of, but there’s always the search function. :-)" />
<meta property="article:published_time" content="2020-11-27T14:53:12+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/2093b630ba0c08d788c29b582667960d676267dd.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="SitePoint Forums | Web Development &amp; Design Community" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/getting-div-content-in-realtime-using-jquery/359984">Getting div content in realtime using jquery</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/javascript/33" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #d3a604'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>JavaScript</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/pandglobal'><span itemprop='name'>pandglobal</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-11-27T01:39:17Z'>
              <time itemprop='dateModified' datetime='2020-11-27T09:09:31Z' class='post-time'>
                November 27, 2020,  9:09am
              </time>
          <span itemprop='position'>#1</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Life savers,</p>
<p>please i need help in getting contents from a div into another div in real time and also how to get values from sessions and show it in another div in real time.</p>
<p>I have a div <span class="hashtag">#messageLog</span> as id and it gets its content in ajax call so the page never reloads, but div <span class="hashtag">#shownewMessage</span> is a static empty html div and i want to pass the ajax contents from <span class="hashtag">#messageLog</span> into <span class="hashtag">#shownewMessage</span>.</p>
<p>I did</p>
<pre><code class="lang-auto">var getnew = $('#messageLog').val();
$('#shownewMessage').html(getnew);

</code></pre>
<p>The above shows the content but only works when page reloads, and since <span class="hashtag">#messageLog</span> is using ajax to get its contents it makes the other div not to get the real time values since the page is not reloading.<br>
please any work around on this?</p>
<p>also i have the same contents in session and can i write jquery function that will get those session values in realtime and put its contents in <span class="hashtag">#shownewMessage</span> div without page reload.<br>
helps is highly appreciated.<br>
Thanks.</p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="2" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/pandglobal'><span itemprop='name'>pandglobal</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-11-27T01:57:47Z' class='post-time'>
                November 27, 2020,  1:57am
              </time>
              <meta itemprop='dateModified' content='2020-11-27T01:57:47Z'>
          <span itemprop='position'>#2</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Am considering using setInterval and set it to run every 10secs as to output the content but i dont if such looping while affect my website and loading speed?</p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/droopsnoot'><span itemprop='name'>droopsnoot</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-11-27T09:09:19Z' class='post-time'>
                November 27, 2020,  9:09am
              </time>
              <meta itemprop='dateModified' content='2020-11-27T09:09:19Z'>
          <span itemprop='position'>#3</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I’ll move this to the Javascript section, as there is no PHP content in here.</p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/Paul_Wilkins'><span itemprop='name'>Paul_Wilkins</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-11-27T10:09:04Z'>
              <time itemprop='dateModified' datetime='2020-11-27T10:09:37Z' class='post-time'>
                November 27, 2020, 10:09am
              </time>
          <span itemprop='position'>#4</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="pandglobal" data-post="1" data-topic="359984" data-full="true">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/pandglobal/40/85717_2.png" class="avatar"> pandglobal:</div>
<blockquote>
<pre><code class="lang-auto">var getnew = $('#messageLog').val();
$('#shownewMessage').html(getnew);
</code></pre>
</blockquote>
</aside>
<p>You can use setInterval for this. I recommend an update time of 250ms which is enough to appear fast, without overly taxing the web browser.</p>
<pre><code class="lang-auto">var timer = setInterval(function () {
    var getnew = $('#messageLog').val();
    $('#shownewMessage').html(getnew);
}, 250);
</code></pre>
<p>Later on if you want to remove it you can use clearInterval:</p>
<pre><code class="lang-auto">clearInterval(timer);</code></pre>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/m3g4p0p'><span itemprop='name'>m3g4p0p</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-11-27T10:35:46Z'>
              <time itemprop='dateModified' datetime='2020-11-27T10:43:21Z' class='post-time'>
                November 27, 2020, 10:43am
              </time>
          <span itemprop='position'>#5</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="pandglobal" data-post="1" data-topic="359984">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/pandglobal/40/85717_2.png" class="avatar"> pandglobal:</div>
<blockquote>
<p>I did</p>
<pre><code class="lang-auto">var getnew = $('#messageLog').val();
$('#shownewMessage').html(getnew);

</code></pre>
<p>The above shows the content but only works when page reloads, and since <span class="hashtag">#messageLog</span> is using ajax to get its contents it makes the other div not to get the real time values since the page is not reloading.</p>
</blockquote>
</aside>
<p>Hi <a class="mention" href="/community/u/pandglobal">@pandglobal</a>, so <code>#messageLog</code> is an input element? In this case you can add a regular event listener; change events will not only get dispatched by user input, but also when setting the value with JS:</p>
<pre><code class="lang-javascript">$('#messageLog').on('change', function () {
  $('#shownewMessage').html(this.value)
})

// Mocking AJAX updates...
setInterval(function () {
  $('#messageLog').val(Date.now())
}, 1000)
</code></pre>
<p>But then again, why don’t you just update the <code>#shownewMessage</code> HTML right within your AJAX callback where you are also setting the <code>#messageLog</code> value?</p>
<p><strong>PS:</strong> BTW you can also monitor any DOM updates using a <a href="https://developer.mozilla.org/en-US/docs/Web/API/MutationObserver">mutation observer</a>; this would also work if <code>#messageLog</code> is not an input element:</p>
<pre><code class="lang-javascript">var message = document.getElementById('shownewMessage')
var log = document.getElementById('messageLog')

var observer = new MutationObserver(function () {
  message.innerHTML = log.innerHTML
})

observer.observe(log, { childList: true })
</code></pre>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="2" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/pandglobal'><span itemprop='name'>pandglobal</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-11-27T10:53:46Z' class='post-time'>
                November 27, 2020, 10:53am
              </time>
              <meta itemprop='dateModified' content='2020-11-27T10:53:46Z'>
          <span itemprop='position'>#6</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote group-Advisors" data-username="Paul_Wilkins" data-post="4" data-topic="359984">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/paul_wilkins/40/40217_2.png" class="avatar"> Paul_Wilkins:</div>
<blockquote>
<p>recommend an update time of 250ms which is enough to appear fast, without overly</p>
</blockquote>
</aside>
<p>Thanks alot was bothered about its effect on my site but now you confirmed am good at 250ms</p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/pandglobal'><span itemprop='name'>pandglobal</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-11-27T11:00:45Z' class='post-time'>
                November 27, 2020, 11:00am
              </time>
              <meta itemprop='dateModified' content='2020-11-27T11:00:45Z'>
          <span itemprop='position'>#7</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote group-Mentors" data-username="m3g4p0p" data-post="5" data-topic="359984">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/m3g4p0p/40/30181_2.png" class="avatar"> m3g4p0p:</div>
<blockquote>
<pre><code class="lang-auto">$('#messageLog').on('change', function () {
  $('#shownewMessage').html(this.value)
})
</code></pre>
</blockquote>
</aside>
<p>I sincerely love this method, so lovely i will try it out now.</p>
<p>I which i can get this to work in getting a session variable.</p>
<p>I have a session variable $_SESSION [‘response’]  and i don’t know how to read that content and get it to display in a html using JavaScript. So as to have the realtime change effect.</p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/pandglobal'><span itemprop='name'>pandglobal</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-11-27T11:05:00Z' class='post-time'>
                November 27, 2020, 11:05am
              </time>
              <meta itemprop='dateModified' content='2020-11-27T11:05:00Z'>
          <span itemprop='position'>#8</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote group-Mentors" data-username="m3g4p0p" data-post="5" data-topic="359984">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/m3g4p0p/40/30181_2.png" class="avatar"> m3g4p0p:</div>
<blockquote>
<pre><code class="lang-auto">var observer = new MutationObserver(function () {
  message.innerHTML = log.innerHTML
})

observer.observe(log, { childList: true })
</code></pre>
</blockquote>
</aside>
<p>Am new to this flow, does it work in all browsers and can work with getting session variables too?</p>
<p>Thanks alot am grateful for your superb contributions</p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/m3g4p0p'><span itemprop='name'>m3g4p0p</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <meta itemprop='datePublished' content='2020-11-27T11:14:15Z'>
              <time itemprop='dateModified' datetime='2020-11-27T11:16:32Z' class='post-time'>
                November 27, 2020, 11:16am
              </time>
          <span itemprop='position'>#9</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="pandglobal" data-post="8" data-topic="359984">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/pandglobal/40/85717_2.png" class="avatar"> pandglobal:</div>
<blockquote>
<p>does it work in all browsers</p>
</blockquote>
</aside>
<p>Yep, check the browser compatibility table in the link I provided… for convenience:</p>
<aside class="onebox allowlistedgeneric">
  <header class="source">
      <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/e/8ee5731d9f9aa0c8dbc9df8a6b5fed1440be5cb9.png" class="site-icon" width="32" height="32">
      <a href="https://developer.mozilla.org/en-US/docs/Web/API/MutationObserver#Browser_compatibility" target="_blank" rel="noopener">MDN Web Docs</a>
  </header>
  <article class="onebox-body">
    <img src="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84_2_500x500.png" class="thumbnail onebox-avatar" width="500" height="500" srcset="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84_2_500x500.png, https://aws1.discourse-cdn.com/sitepoint/original/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84.png 1.5x, https://aws1.discourse-cdn.com/sitepoint/original/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84.png 2x" data-small-upload="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/5/e5c522d667c53fbfb0ada5f535969c16f9748c84_2_10x10.png">

<h3><a href="https://developer.mozilla.org/en-US/docs/Web/API/MutationObserver#Browser_compatibility" target="_blank" rel="noopener">MutationObserver</a></h3>

<p>The MutationObserver interface provides the ability to watch for changes being made to the DOM tree. It is designed as a replacement for the older Mutation Events feature, which was part of the DOM3 Events specification.</p>


  </article>
  <div class="onebox-metadata">
    
    
  </div>
  <div style="clear: both"></div>
</aside>

<aside class="quote no-group" data-username="pandglobal" data-post="8" data-topic="359984">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/pandglobal/40/85717_2.png" class="avatar"> pandglobal:</div>
<blockquote>
<p>can work with getting session variables</p>
</blockquote>
</aside>
<p>No, getting your server session variables is a different matter altogether; you’ll need to expose them to your frontend, and using AJAX would indeed be an option.</p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/pandglobal'><span itemprop='name'>pandglobal</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-11-27T11:38:30Z' class='post-time'>
                November 27, 2020, 11:38am
              </time>
              <meta itemprop='dateModified' content='2020-11-27T11:38:30Z'>
          <span itemprop='position'>#10</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote group-Mentors" data-username="m3g4p0p" data-post="9" data-topic="359984">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/m3g4p0p/40/30181_2.png" class="avatar"> m3g4p0p:</div>
<blockquote>
<p>No, getting your server session variables</p>
</blockquote>
</aside>
<p>okay thanks, but is there a thread on it already here on sitepoint so i can look at it but if not i can open a new thread on it and see if i can get help on it.</p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="1" />
           <span class='post-likes'>1 Like</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/m3g4p0p'><span itemprop='name'>m3g4p0p</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/getting-div-content-in-realtime-using-jquery/359984">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-11-27T14:53:12Z' class='post-time'>
                November 27, 2020,  2:53pm
              </time>
              <meta itemprop='dateModified' content='2020-11-27T14:53:12Z'>
          <span itemprop='position'>#11</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Not one I’m immediately aware of, but there’s always the search function. <code>:-)</code></p>
        </div>

        <meta itemprop='headline' content='Getting div content in realtime using jquery'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <!--//
<div class="proper-ad-unit ad-sticky">
    <div id="proper-ad-sitepoint_main_1">
        <script> 
            // propertag && propertag.cmd.push(function() { proper_display('sitepoint_main_1'); });
        </script>
    </div>
</div>
//-->
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/0225110c0cade405081c48cfc831f094dcd8909d.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
