Get 404 page after publishing, editing post in WordPress

Since the last 3-4 weeks, whenever I go on to publish, schedule or edit a published post on my WordPress blog, the pages stays this way for 1-5 minutes. After that, I see the 404 Page Not Found Error Page.

This happens even when I activate/deactivate a plugin or edit a user or activate or change some setting in the WordPress panel.

I’m the admin and only I face this problem as I have editing publishing scheduling rights. Other authors do not face this problem. Posts however get saved as Drafts.

This almost always happens - only say 10% of the times, it actually works.

I have installed no new plugins. Only updated WordPress and plugins to latest versions. I uploaded freshly downloaded WordPress files. I have also tried it with the default theme. I have disabled all plugins and tried, but still face this issue. I even changed the post draft auto-save time interval from 1 minute to 5 minutes. It did not help.

Anyone have any ideas? Help would be most appreciated.

Maybe the logs can give you a bit more information why this is happening. Do you have access to your server logs? And have a look at them

Yes, I may be able to access the. Will contact the Host today. Give me a day to get back to you on this. Anything I should be looking for, particularly?

it’s your server problem and it’s happen with me 2 month ago.when i contact my host my problem is solve after 72 hours. and it’s solved.