<!DOCTYPE html>
<html lang="en-US">
  <head>
    <meta charset="utf-8">
    <title>Flexbox vs Inline-Block - HTML &amp; CSS - The SitePoint Forums</title>
    <meta name="description" content="Hello.  Still trying to get the hang of Flexbox and mobile development… 
I am working on a couple of web pages that require having a product thumbnail and then product description side-by-side.  This includes a checkout &amp;hellip;">
    <meta name="generator" content="Discourse 2.5.0.beta5 - https://github.com/discourse/discourse version c8370b9c78df1161aa3db2699bbd53c3e04b9925">
<link rel="icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/0/6/06fa311765b08c4cdf3963f8b19b2e6792559176_2_32x32.ico">
<link rel="apple-touch-icon" type="image/png" href="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/2/5/251fedb1e929595050b23e6f0ce837f0d59d7be1_2_180x180.png">
<meta name="theme-color" content="#ffffff">
<meta name="viewport" content="width=device-width, initial-scale=1.0, minimum-scale=1.0, user-scalable=yes, viewport-fit=cover">
<meta name="discourse-base-uri" content="/community">
<link rel="canonical" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432?page=2" />
<script type="application/ld+json">{"@context":"http://schema.org","@type":"WebSite","url":"https://www.sitepoint.com/community","potentialAction":{"@type":"SearchAction","target":"https://www.sitepoint.com/community/search?q={search_term_string}","query-input":"required name=search_term_string"}}</script>
<link rel="search" type="application/opensearchdescription+xml" href="https://www.sitepoint.com/community/opensearch.xml" title="The SitePoint Forums Search">

      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_f52dabc91aa8b3283c5b04fec0890a2d7d11a75f.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop" data-theme-id="495"/>
      <link href="https://sjc5.discourse-cdn.com/sitepoint/community/stylesheets/desktop_theme_495_396f932ed0507966541f394e5829bf93e77aa1c3.css?__ws=www.sitepoint.com" media="all" rel="stylesheet" data-target="desktop_theme" data-theme-id="495"/>
    




<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/fb25ec51cebc2642582754450c5a992887290bec.js?__ws=www.sitepoint.com"></script>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/8e09b370c6600f8a72ea3a60c148004f34767967.js?__ws=www.sitepoint.com"></script>
    <meta id="data-ga-universal-analytics" data-tracking-code="UA-30131-1" data-json="{&quot;cookieDomain&quot;:&quot;auto&quot;}" data-auto-link-domains="">

<link rel="preload" href="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-00f5cdf7dfd45cba1ae2d258c3366c371c5671023250abbd964a1f16fc2c11a7.gz.js" as="script">
<script src="https://aws1.discourse-cdn.com/sitepoint/assets/google-universal-analytics-00f5cdf7dfd45cba1ae2d258c3366c371c5671023250abbd964a1f16fc2c11a7.gz.js"></script>


        <link rel="alternate" type="application/rss+xml" title="RSS feed of &#39;Flexbox vs Inline-Block&#39;" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432.rss" />
    <meta property="og:site_name" content="The SitePoint Forums" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:image" content="https://aws1.discourse-cdn.com/sitepoint/original/3X/c/f/cf11b3ed553d6c359d3dcc08377cc4b121fe8bf0.png" />
<meta property="og:url" content="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432/35" />
<meta name="twitter:url" content="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432/35" />
<meta property="og:title" content="Flexbox vs Inline-Block" />
<meta name="twitter:title" content="Flexbox vs Inline-Block" />
<meta property="og:description" content="@UpstateLeafPeeper  I have created another page using your style and hopefully it is easier to understand. I had to combine the single line tags into a single tag:  John_Betong-002.php" />
<meta name="twitter:description" content="@UpstateLeafPeeper  I have created another page using your style and hopefully it is easier to understand. I had to combine the single line tags into a single tag:  John_Betong-002.php" />
<meta property="article:published_time" content="2020-06-30T04:43:51+00:00" />
<meta property="og:ignore_canonical" content="true" />



    
  </head>
  <body class="crawler">
    <!--
<script type="text/discourse-plugin" version="0.8">
    api.modifyClass('component:topic-list', {
        didInsertElement: function() {
            this._super();
            loadBsaTopicList();
        }
    });
    
    function loadBsaTopicList() {
        var topicList = document.querySelector('.topic-list');
        var totalTopicItems = topicList.querySelectorAll('.topic-list .topic-list-item').length;
        var rowIndex = totalTopicItems >= 5 ? 6 : totalTopicItems + 1; // Header row is included in total row count
        var row = topicList.insertRow(rowIndex);
        row.className = 'hide';
        row.id = 'bsa-topic-row'
        var cell = row.insertCell(0);
        cell.colSpan = 6;
        cell.innerHTML = '<div id="bsa-topic-list-outlet"></div>';
        if(typeof _bsa !== 'undefined' && _bsa) {
            var zoneKey = 'CVADE5Q7';
            var adScript = document.querySelector('script[id^="_bsa_srv-' + zoneKey + '"]');
            if(adScript) {
                adScript.parentNode.removeChild(adScript);
            }
            _bsa.init('default', zoneKey, '', {
                target: '#bsa-topic-list-outlet',
                id: 'bsa-topic-list',
                // forwardedip value is for testing only - src: http://customads.bsademo.com/reference/server-side.html
                path: 'https://srv.buysellads.com/ads/' + zoneKey + '.json?forcenads=1'
            });
            _bsa.callback = function(bsaAd) {
                var ad = bsaAd.ads[0];
                if (bsaAd.key === zoneKey) {
                    document.querySelector('#bsa-topic-row').classList.remove('hide');
                    var bsaWrapper = document.querySelector('#bsa-topic-list');
                    var adLinkWrapper = bsaWrapper.querySelector('a._default_');
                    var titleEl = adLinkWrapper.querySelector('.default-title');
                    var descEl = adLinkWrapper.querySelector('.default-description');
    
                    var wrapper = document.createElement('div');
                    var cta = document.createElement('span');

                    wrapper.className = 'default-content';
                    cta.className = 'default-cta';
                    cta.innerText = ad.callToAction;
                    cta.style.backgroundColor = ad.ctaBackgroundColor;
                    cta.style.color = ad.ctaTextColor;
    
                    adLinkWrapper.appendChild(wrapper);
                    adLinkWrapper.appendChild(cta);
                    wrapper.appendChild(titleEl);
                    wrapper.appendChild(descEl);
                }
            };
        }
    }
</script>
-->
<noscript>
  <a class="header-link u-button" target="_blank" href="/themes?utm_source=community&amp;utm_medium=top-nav" tabindex="2">Themes</a>
  <a class="header-link" href="/versioning-show?utm_source=community&amp;utm_medium=top-nav" tabindex="3">Podcast</a>
  <a class="header-link" href="/?utm_source=community&amp;utm_medium=top-nav" tabindex="5">Articles</a>
  <a class="header-link u-button" target="_blank" href="/premium/topics/all?utm_source=community&amp;utm_medium=top-nav" tabindex="6">Premium</a>
</noscript>

<!-- Start Alexa Certify Javascript -->

<noscript><img src="https://d5nxst8fruw4z.cloudfront.net/atrk.gif?account=3/2Rk1ao6C526C" style="display:none" height="1" width="1" alt=""></noscript>
<!-- End Alexa Certify Javascript -->


<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/de505def0910c61bac51ad5aafe5a62e28ea5dd8.js?__ws=www.sitepoint.com"></script>
    <header>
      <a href="/community/">
          <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg" alt="The SitePoint Forums" id="site-logo" style="max-width: 150px;">
      </a>
    </header>
    <div id="main-outlet" class="wrap">
        <div id="topic-title">
    <h1>
      <a href="/community/t/flexbox-vs-inline-block/354432">Flexbox vs Inline-Block</a>
    </h1>

      <div class="topic-category" itemscope itemtype="http://schema.org/BreadcrumbList">
          <span itemprop="itemListElement" itemscope itemtype="http://schema.org/ListItem">
            <a href="https://www.sitepoint.com/community/community/c/html-css" class="badge-wrapper bullet" itemprop="item">
              <span class='badge-category-bg' style='background-color: #ba5401'></span>
              <span class='badge-category clear-badge'>
                <span class='category-name' itemprop='name'>HTML &amp; CSS</span>
              </span>
            </a>
            <meta itemprop="position" content="1" />
          </span>
      </div>

  </div>

  


      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-28T05:15:30Z' class='post-time'>
                June 28, 2020,  5:15am
              </time>
              <meta itemprop='dateModified' content='2020-06-28T05:15:30Z'>
          <span itemprop='position'>#15</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/coothead">@coothead</a>,</p>
<p>Please see the attached code and tell me what you think…</p>
<p><a class="attachment" href="/community/uploads/short-url/pOMz8XZQ1eeoUio9q7ZeS02ULH.zip">sp_review-cart_02.zip</a> (273.8 KB)</p>
<p>(You will need to adjust the IMG path…)</p>
<p>I think things look really sharp, and they seem to work okay, but I’m not sure how “responsive” things are, or how efficient my code is.  <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/4/84125cb3a26d4aa5fe6af0018729905ef73bd73c.gif?v=9" title=":wonky:" class="emoji emoji-custom" alt=":wonky:"></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>
          <meta itemprop='keywords' content=''>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

            <div class='crawler-linkback-list' itemscope itemtype='http://schema.org/ItemList'>
                  <div itemprop='itemListElement' itemscope itemtype='http://schema.org/ListItem'>
                    <a href="https://www.sitepoint.com/community/t/how-new-is-new-enough-for-html-css/354439/4" itemprop='item'>
                      <meta itemprop='url' content='https://www.sitepoint.com/community/t/how-new-is-new-enough-for-html-css/354439/4'>
                      <meta itemprop='position' content='2'>
                      <span itemprop='name'>How new is new enough for HTML/CSS?</span>
                    </a>
                  </div>
            </div>
      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-28T21:05:08Z' class='post-time'>
                June 28, 2020,  9:05pm
              </time>
              <meta itemprop='dateModified' content='2020-06-28T21:05:08Z'>
          <span itemprop='position'>#16</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi there UpstateLeafPeeper,</p>
<p>the page seems to work reasonably well on page width reduction<br>
but has problems in various browsers on desktop width, see the<br>
attachment for snapshots.</p>
<p><a class="attachment" href="/community/uploads/short-url/Au1ifOnkW1ZPR6HOSAWUPLxgHli.zip">brower-shots.zip</a> (260.2 KB)</p>
<p>I am disappointed to see that you are still  using <strong>px units</strong> where <strong>em<br>
or rem</strong> would be more appropriate.</p>
<p><em>coothead</em>.</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-28T21:23:47Z' class='post-time'>
                June 28, 2020,  9:23pm
              </time>
              <meta itemprop='dateModified' content='2020-06-28T21:23:47Z'>
          <span itemprop='position'>#17</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/coothead">@coothead</a>,</p>
<aside class="quote no-group" data-username="coothead" data-post="16" data-topic="354432" data-full="true">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/coothead/40/10354_2.png" class="avatar"> coothead:</div>
<blockquote>
<p>the page seems to work reasonably well on page width reduction but has problems in various browsers on desktop width, see the attachment for snapshots.</p>
</blockquote>
</aside>
<p>Each of those is a screenshot of a single browser window?</p>
<p>Things are so jumbled up it’s hard to tell what I am looking at.</p>
<p>I tried things in Firefox’s Responsive Design Mode last night on things like various iPhones and Tablets and I thought the page looked awesome.</p>
<p>Am confused by your screenshots…</p>
<aside class="quote no-group" data-username="coothead" data-post="16" data-topic="354432" data-full="true">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/coothead/40/10354_2.png" class="avatar"> coothead:</div>
<blockquote>
<p>I am disappointed to see that you are still  using <strong>px units</strong> where <strong>em<br>
or rem</strong> would be more appropriate.</p>
</blockquote>
</aside>
<p>You’re often disappointed in me!  <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02a1faf5c304c9786b0783439531204d9d204d04.gif?v=9" title=":wink:" class="emoji emoji-custom" alt=":wink:"></p>
<p>I guess I tend to still use pixels when it comes to spacing and boxes and REMs more for text.</p>
<p>So you recommend using EMs or REMs for everything?</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="2" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-28T21:46:25Z' class='post-time'>
                June 28, 2020,  9:46pm
              </time>
              <meta itemprop='dateModified' content='2020-06-28T21:46:25Z'>
          <span itemprop='position'>#18</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/coothead">@coothead</a>,</p>
<p>Attached are screenshots from Chrome’s “Toggle Device Toolbar”…</p>
<p>Things look equally good from what I tried in Firefox last night.</p>
<p>(I cannot speak to IE or Edge since my Dev environment is on my Mac.)</p>
<p>Not sure where/how you are getting such strange results…  <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/8/4/84125cb3a26d4aa5fe6af0018729905ef73bd73c.gif?v=9" title=":wonky:" class="emoji emoji-custom" alt=":wonky:"></p>
<p><a class="attachment" href="/community/uploads/short-url/zrImm8QoaHGZcygTiIrt3O563VJ.zip">MobileScreenshots.zip</a> (1.3 MB)</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-28T22:20:18Z' class='post-time'>
                June 28, 2020, 10:20pm
              </time>
              <meta itemprop='dateModified' content='2020-06-28T22:20:18Z'>
          <span itemprop='position'>#19</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group quote-modified" data-username="UpstateLeafPeeper" data-post="17" data-topic="354432">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/u/ce7236/40.png" class="avatar"> UpstateLeafPeeper:</div>
<blockquote>
<p><font color="#068">1. Each of those is a screenshot of a single browser window?<br>
2. Things are so jumbled up it’s hard to tell what I am looking at.<br>
3.  I tried things in Firefox’s Responsive Design Mode last night<br>
on things like various iPhones and Tablets and I thought the<br>
page looked awesome.<br>
4. Am confused by your screenshots…</font></p>
</blockquote>
</aside>
<ol>
<li>Yes.</li>
<li>Each of the screen shots -(1366 x 768 ) - has the browser’s name.</li>
<li>The screen shot for Firefox shows the only acceptable rendition.</li>
<li>I am sorry to here that, but I do not have the ability to  help you with<br>
that condition.</li>
</ol>
<aside class="quote no-group quote-modified" data-username="UpstateLeafPeeper" data-post="17" data-topic="354432">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/u/ce7236/40.png" class="avatar"> UpstateLeafPeeper:</div>
<blockquote>
<p><font color="#069">1.  You’re often disappointed in me! <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02a1faf5c304c9786b0783439531204d9d204d04.gif?v=9" title=":wink:" class="emoji emoji-custom" alt=":wink:"><br>
2.  I guess I tend to still use pixels when it comes to spacing and boxes<br>
and REMs more for text.<br>
3. So you recommend using EMs or REMs for everything?</font></p>
</blockquote>
</aside>
<ol>
<li>Not you personally.</li>
<li>
<code>border: 1px solid #000;</code> seems like a reasonable use for a  <strong>px unit</strong>.</li>
<li>I will give you a treat for that…<br>
&nbsp;<br>
<a href="https://forums.cutcodedown.com/index.php?topic=238.msg1096#msg1096" data-bbcode="true">deafshadow’s thoughts on the use of the px unit</a><br>
&nbsp;<br>
…but be aware that it’ not suitable reading  for the fainthearted. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/5/f/5f6daf7fe1bb1446f28998770f13f84c9fc95e7c.gif?v=9" title=":rofl:" class="emoji emoji-custom" alt=":rofl:">
</li>
</ol>
<p><em>coothead</em></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-28T22:39:16Z' class='post-time'>
                June 28, 2020, 10:39pm
              </time>
              <meta itemprop='dateModified' content='2020-06-28T22:39:16Z'>
          <span itemprop='position'>#20</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi there UpstateLeafPeeper,</p>
<p>My screenshots were taken on Windows 10,<br>
which is not my normal OS, but was used<br>
because it contained a wide range of test<br>
browsers.</p>
<p>The screen resolution was 1366 x 768</p>
<p>It appears that you cannot test your code in<br>
Windows and I cannot test mine on a MAC</p>
<p>The bottom line seems to be that your pages<br>
render as you intended on screen  widths that<br>
you set with this code…<br>
<code>@media only screen and (min-width: 768px)</code></p>
<p><em>coothead</em></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-28T22:56:16Z' class='post-time'>
                June 28, 2020, 10:56pm
              </time>
              <meta itemprop='dateModified' content='2020-06-28T22:56:16Z'>
          <span itemprop='position'>#21</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/coothead">@coothead</a>,</p>
<p>This time I think it’s you.  <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02a1faf5c304c9786b0783439531204d9d204d04.gif?v=9" title=":wink:" class="emoji emoji-custom" alt=":wink:"></p>
<p>I just tried the page and thumbnails I uploaded on my notebook, which apparently runs Windows10 Home - who knew? - and looked at things in Edge and IE, and things were fine.</p>
<p>Something is fubared on your computer.</p>
<p>And to that link regarding PX vs EMs…</p>
<p>I obviously like REMs, but computer manufacturers don’t sell things by EM sized monitors as duly noted in your comments about your “1366 X 768” computer.</p>
<p>So is there some chart that translates monitor resolution and pixels into EMs?</p>
<p>When it comes to things like paragraphs, EMs make sense.  But when trying to size a box, PXs are more intuitive to me.</p>
<p>I’ll gladly switch to an all EM mentality, but I need help in visualizing things in EMs.</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">

            <link itemprop="image" href="https://www.sitepoint.com/community//discourse-cloud-file-uploads.s3.dualstack.us-west-2.amazonaws.com/sitepoint/original/3X/e/a/ea2a13fff18465a1a563b0df67de85976c6b1470.jpeg">

          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T00:02:27Z' class='post-time'>
                June 29, 2020, 12:02am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T00:02:27Z'>
          <span itemprop='position'>#22</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group quote-modified" data-username="UpstateLeafPeeper" data-post="21" data-topic="354432">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/u/ce7236/40.png" class="avatar"> UpstateLeafPeeper:</div>
<blockquote>
<p><font color="#069">…but computer manufacturers don’t sell things by EM sized monitors</font></p>
</blockquote>
</aside>
<p>Don’t confuse monitor pixels with <strong>the use of pixels within HTML &amp; CSS</strong> .<br>
There is no need for theory, in CSS pixels don’t scale.</p>
<p><strong>Source:-</strong></p>
<p><a href="https://medium.com/@julienetienne/pixels-are-dead-faa87cd8c8b9" data-bbcode="true"> Pixels Are Dead: Why You Should Stop Using Pixels In CSS</a></p>
<p>I am now back on Linix Mint OS and here is a Vivaldi screenshot at 84.94em…</p>
<p><div class="lightbox-wrapper"><a class="lightbox" href="https://aws1.discourse-cdn.com/sitepoint/original/3X/e/a/ea2a13fff18465a1a563b0df67de85976c6b1470.jpeg" data-download-href="/community/uploads/short-url/xpvSyUCpxY3Z2uIGdn4AF4YrwWY.jpeg?dl=1" title="vivaldi"><img src="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/a/ea2a13fff18465a1a563b0df67de85976c6b1470_2_690x387.jpeg" alt="vivaldi" data-base62-sha1="xpvSyUCpxY3Z2uIGdn4AF4YrwWY" width="690" height="387" srcset="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/a/ea2a13fff18465a1a563b0df67de85976c6b1470_2_690x387.jpeg, https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/a/ea2a13fff18465a1a563b0df67de85976c6b1470_2_1035x580.jpeg 1.5x, https://aws1.discourse-cdn.com/sitepoint/original/3X/e/a/ea2a13fff18465a1a563b0df67de85976c6b1470.jpeg 2x" data-small-upload="https://aws1.discourse-cdn.com/sitepoint/optimized/3X/e/a/ea2a13fff18465a1a563b0df67de85976c6b1470_2_10x10.png"><div class="meta"><svg class="fa d-icon d-icon-far-image svg-icon" aria-hidden="true"><use xlink:href="#far-image"></use></svg><span class="filename">vivaldi</span><span class="informations">1366×768 91.3 KB</span><svg class="fa d-icon d-icon-discourse-expand svg-icon" aria-hidden="true"><use xlink:href="#discourse-expand"></use></svg></div></a></div></p>
<p>I really don’t think that my computer is fubared. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/1/a/1a8bd013a2f4c377b0007694522fc14ef2c51851.gif?v=9" title=":unhappy:" class="emoji emoji-custom" alt=":unhappy:"></p>
<p>You may be interested a script that can be run temporarily in a<br>
page and will then display it’s width in ems.</p>
<p><a class="attachment" href="/community/uploads/short-url/tCawnW0H7DRGd8CYZxopg8sEGJM.zip">em-width-display.zip</a> (1.1 KB)</p>
<p><em>coothead</em></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T00:32:00Z' class='post-time'>
                June 29, 2020, 12:32am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T00:32:00Z'>
          <span itemprop='position'>#23</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group quote-modified" data-username="coothead" data-post="22" data-topic="354432" data-full="true">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/coothead/40/10354_2.png" class="avatar"> coothead:</div>
<blockquote>
<p>I am now back on Linix Mint OS and here is a Vivaldi screenshot at 84.94em…</p>
<p>I really don’t think that my computer is fubared. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/1/a/1a8bd013a2f4c377b0007694522fc14ef2c51851.gif?v=9" title=":unhappy:" class="emoji emoji-custom" alt=":unhappy:"></p>
</blockquote>
</aside>
<p>So what is the supposed issue, because I cannot create it in macOS or Windows10 or on Firefox, Chrome, Brave, IE or Edge on laptop, desktop, or mobile…</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T00:57:31Z' class='post-time'>
                June 29, 2020, 12:57am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T00:57:31Z'>
          <span itemprop='position'>#24</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Hi there UpstateLeafPeeper,</p>
<p>I downloaded your attachment from post <strong><span class="hashtag">#15</span></strong> again and retested the page.</p>
<p>It now displays as you have always insisted that it should.</p>
<p>I must have messed up the code in some way when adjusting the image paths. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/9/d/9dcc4896b3d664d3ef34e43a9c20fde6a7d5888b.gif?v=9" title=":eek:" class="emoji emoji-custom" alt=":eek:"></p>
<p>I apologise for the distress and confusion that I must have  given you.</p>
<p><em>coothead</em></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="2" />
           <span class='post-likes'>2 Likes</span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T01:02:33Z' class='post-time'>
                June 29, 2020,  1:02am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T01:02:33Z'>
          <span itemprop='position'>#25</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>Looks like I can cancel that order I was placing on eBay for a used desktop running Linux Mint with Vivaldi!!  <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/6/c/6c3193d1dd46244da3c8c6f719c9f5e2abdd5ae8.gif?v=9" title=":biggrin:" class="emoji emoji-custom" alt=":biggrin:"></p>
<p>Glad I made a small step forward…</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T01:05:51Z' class='post-time'>
                June 29, 2020,  1:05am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T01:05:51Z'>
          <span itemprop='position'>#26</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="UpstateLeafPeeper" data-post="25" data-topic="354432">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/u/ce7236/40.png" class="avatar"> UpstateLeafPeeper:</div>
<blockquote>
<p>Glad I made a small step forward…</p>
</blockquote>
</aside>
<p>I seem to be making some big steps backwards. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/1/a/1a8bd013a2f4c377b0007694522fc14ef2c51851.gif?v=9" title=":unhappy:" class="emoji emoji-custom" alt=":unhappy:"></p>
<p>Senile dementia may be starting to kick in. <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/9/d/9dcc4896b3d664d3ef34e43a9c20fde6a7d5888b.gif?v=9" title=":eek:" class="emoji emoji-custom" alt=":eek:"></p>
<p><em>coothead</em></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T01:25:23Z' class='post-time'>
                June 29, 2020,  1:25am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T01:25:23Z'>
          <span itemprop='position'>#27</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/coothead">@coothead</a>,</p>
<p>We still love ya…  <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/0/2/02a1faf5c304c9786b0783439531204d9d204d04.gif?v=9" title=":wink:" class="emoji emoji-custom" alt=":wink:"></p>
<p>Is it fair to assume that testing my code on a Retina MacBook Pro is sufficient?  That is, I assume the resolution on my laptop competes size wise with most standard desktops, unless a person has a really big, hi-def monitor.</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T11:27:14Z' class='post-time'>
                June 29, 2020, 11:27am
              </time>
              <meta itemprop='dateModified' content='2020-06-29T11:27:14Z'>
          <span itemprop='position'>#29</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/upstateleafpeeper">@UpstateLeafPeeper</a>,</p>
<p>did you try the em-width display utility?</p>
<p><em>coothead</em></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="2" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/John_Betong'><span itemprop='name'>John_Betong</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-29T14:07:45Z' class='post-time'>
                June 29, 2020,  2:07pm
              </time>
              <meta itemprop='dateModified' content='2020-06-29T14:07:45Z'>
          <span itemprop='position'>#30</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p>I checked on the CSS used to display the books and was amazed at the script involved! I was convinced that the CSS could be drastically reduced…</p>
<p>…because CSS is cascaded from the top down and <em><strong>most</strong></em> tags are either blocks or inline elements.</p>
<p>I started at the top outer book div and stated modifying.</p>
<p>I rewrote the block and used this method:</p>
<ol>
<li>created a <strong>book</strong> class</li>
<li>added the image and resized</li>
<li>added the h2 tag with text</li>
<li>created a .hhh {display: none;}</li>
<li>added the remaining text all in divs with the hhh class</li>
<li>added background colours<br>
a.  .bga {background-color: aqua}<br>
b.  .bgl {background-color: lime}<br>
c.  .bgr {background-color: <span class="hashtag">#fcc</span>;}</li>
<li>added hhh to text not yet mdified</li>
<li>gradually revealed text and modified</li>
</ol>
<h4>The CSS:</h4>
<pre><code class="lang-auto">&lt;style&gt;
body{
  font-family: Helvetica, Arial, Sans-Serif;
  font-weight: normal;
  line-height: 1.4;
  font-size: 0.9em;
  font-size: 1.0em;
}  

/* ===================================== */
.book {margin: 0 0 4em 0.0em;}
.img {
  width: 8.45em; height: 150px; 
  margin: 0 2em 0 0;
  text-align: center;
  vertical-align: middle;
}
.img img {
  height: auto;
  max-height: 150px;
}
.bd1 {outline: solid 1px #ddd;}
.bg0 {background-color: #ffe;}
.bg1 {background-color: #eff;}
.fll {float: left;}
.fs2 {font-size: 1.1rem;}
.fs3 {font-size: 0.88rem;}
.fs4 {font-size: 1.1rem;} 
.fss {font-size: x-small;}
.fwn {font-weight: normal;}
.hhh {display: none;
.lh0 {line-height: 1.0;}
.ooo {border: 0; padding: 0;}
/* ===================================== */
.mga {margin: 0 auto;}
.w88 {width: 88%; max-width: 70em;}
&lt;/style&gt;
</code></pre>
<h4><a href="https://this-is-a-test-to-see-if-it-works.tk/sp-a/ulp/shopping-cart/menu.php">Online Results</a></h4>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-30T01:11:43Z' class='post-time'>
                June 30, 2020,  1:11am
              </time>
              <meta itemprop='dateModified' content='2020-06-30T01:11:43Z'>
          <span itemprop='position'>#31</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="coothead" data-post="29" data-topic="354432" data-full="true">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/coothead/40/10354_2.png" class="avatar"> coothead:</div>
<blockquote>
<p><a class="mention" href="/community/u/upstateleafpeeper">@UpstateLeafPeeper</a>,</p>
<p>did you try the em-width display utility?</p>
<p><em>coothead</em></p>
</blockquote>
</aside>
<p>Yes, I just tried it.  Clever!</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-30T01:14:00Z' class='post-time'>
                June 30, 2020,  1:14am
              </time>
              <meta itemprop='dateModified' content='2020-06-30T01:14:00Z'>
          <span itemprop='position'>#32</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/john_betong">@John_Betong</a>,</p>
<p>I appreciate your efforts, but your coding style is totally unreadable to me.</p>
<p>Only YOU know what all of your codes me, and it’s too much work every time to build a decoding ring.</p>
<p>Easy to read code can be hard enough to try and understand.</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/coothead'><span itemprop='name'>coothead</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-30T01:24:51Z' class='post-time'>
                June 30, 2020,  1:24am
              </time>
              <meta itemprop='dateModified' content='2020-06-30T01:24:51Z'>
          <span itemprop='position'>#33</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="UpstateLeafPeeper" data-post="31" data-topic="354432">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://avatars.discourse.org/v4/letter/u/ce7236/40.png" class="avatar"> UpstateLeafPeeper:</div>
<blockquote>
<p>Clever!</p>
</blockquote>
</aside>
<p>But is it  going to help you <font size="4">px ↠ em </font>? <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/5/f/5f6daf7fe1bb1446f28998770f13f84c9fc95e7c.gif?v=9" title=":rofl:" class="emoji emoji-custom" alt=":rofl:"></p>
<p><em>coothead</em></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="1" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/UpstateLeafPeeper'><span itemprop='name'>UpstateLeafPeeper</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-30T01:43:32Z' class='post-time'>
                June 30, 2020,  1:43am
              </time>
              <meta itemprop='dateModified' content='2020-06-30T01:43:32Z'>
          <span itemprop='position'>#34</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <aside class="quote no-group" data-username="coothead" data-post="33" data-topic="354432" data-full="true">
<div class="title">
<div class="quote-controls"></div>
<img alt="" width="20" height="20" src="https://sjc5.discourse-cdn.com/sitepoint/community/user_avatar/www.sitepoint.com/coothead/40/10354_2.png" class="avatar"> coothead:</div>
<blockquote>
<p>But is it  going to help you <font size="4">px ↠ em </font>? <img src="https://aws1.discourse-cdn.com/sitepoint/original/3X/5/f/5f6daf7fe1bb1446f28998770f13f84c9fc95e7c.gif?v=9" title=":rofl:" class="emoji emoji-custom" alt=":rofl:"></p>
</blockquote>
</aside>
<p>Well, how exactly would I use it?</p>
<p>Open it up in a separate tab?</p>
<p>Insert your code into an existing page?</p>
<p>I read your link about pixels being dead, and I have taken the hint.</p>
<p>Moving forward, I will try to start thinking purely in EMs and REMs, although it will take some getting used to.</p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>
      <div itemscope itemtype='http://schema.org/DiscussionForumPosting' class='topic-body crawler-post'>
        <div class='crawler-post-meta'>
          <div itemprop='publisher' itemscope itemtype="http://schema.org/Organization">
            <meta itemprop='name' content='SitePoint Pty Ltd'>
              <div itemprop='logo' itemscope itemtype="http://schema.org/ImageObject">
                <meta itemprop='url' content='https://aws1.discourse-cdn.com/sitepoint/original/3X/8/2/82f1efb4fd0b9a5b5e8b10083c42aa2a5e86cf3c.svg'>
              </div>
          </div>
          <span class="creator" itemprop="author" itemscope itemtype="http://schema.org/Person">
            <a itemprop="url" href='https://www.sitepoint.com/community/u/John_Betong'><span itemprop='name'>John_Betong</span></a>
            
          </span>

          <link itemprop="mainEntityOfPage" href="https://www.sitepoint.com/community/t/flexbox-vs-inline-block/354432">


          <span class="crawler-post-infos">
              <time itemprop='datePublished' datetime='2020-06-30T04:43:51Z' class='post-time'>
                June 30, 2020,  4:43am
              </time>
              <meta itemprop='dateModified' content='2020-06-30T04:43:51Z'>
          <span itemprop='position'>#35</span>
          </span>
        </div>
        <div class='post' itemprop='articleBody'>
          <p><a class="mention" href="/community/u/upstateleafpeeper">@UpstateLeafPeeper</a></p>
<p>I have created another page using your style and hopefully it is easier to understand. I had to combine the single line tags into a single tag:</p>
<p><a href="https://this-is-a-test-to-see-if-it-works.tk/sp-a/ulp/shopping-cart/John_Betong-002.php"><strong>John_Betong-002.php</strong></a></p>
        </div>

        <meta itemprop='headline' content='Flexbox vs Inline-Block'>

        <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
           <meta itemprop="interactionType" content="http://schema.org/LikeAction"/>
           <meta itemprop="userInteractionCount" content="0" />
           <span class='post-likes'></span>
         </div>

         <div itemprop="interactionStatistic" itemscope itemtype="http://schema.org/InteractionCounter">
            <meta itemprop="interactionType" content="http://schema.org/CommentAction"/>
            <meta itemprop="userInteractionCount" content="0" />
          </div>

      </div>






    </div>
    <footer class="container wrap">
      <nav class='crawler-nav'>
        <ul>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/' itemprop="url">Home </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/categories' itemprop="url">Categories </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/guidelines' itemprop="url">FAQ/Guidelines </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/tos' itemprop="url">Terms of Service </a>
          </span>
        </li>
        <li itemscope itemtype='http://schema.org/SiteNavigationElement'>
          <span itemprop='name'>
            <a href='/community/privacy' itemprop="url">Privacy Policy </a>
          </span>
        </li>
        </ul>
      </nav>
      <p class='powered-by-link'>Powered by <a href="https://www.discourse.org">Discourse</a>, best viewed with JavaScript enabled</p>
    </footer>
    
    <div class="proper-ad-unit ad-sticky">
   <div id="proper-ad-sitepoint_main_1">
       
    </div>
</div>
<script src="https://sjc5.discourse-cdn.com/sitepoint/community/theme-javascripts/b7c2dddc040843c0c556142972c499dd3d93275f.js?__ws=www.sitepoint.com"></script>
  </body>
  
</html>
