Firefox 4 and Roboform 6

I installed Firefox 4 today and was really annoyed to find that the Roboform 6 toolbar no longer works.

Despite their promise of “free updates for life”, Roboform is forcing people into a paid upgrade to version 7. That’s rude and bad business. What bothers me more than the money, though, is having to learn yet another new UI. It looks like I need to learn a new one with FF4, too. I’m sure it’s not that complicated, but when you add all the updated UIs with all my software together, it’s an annoying and time-consuming task.

I really just wanted to stay with Roboform 6.

So now I’m having to spend my work morning figuring out how to solve this, bite it and go to RF7? That makes me die just a little inside - I’m tired of being pushed around like this. But if I choose another password management solution, I have to find a reputable one whose security I feel confident about, and stores info locally. There goes another few hours.



(P.S. That’s the first time I’ve ever used an angry emoticon. Ever. That’s how annoyed I am.)

FireFox 4 default theme is horrible, I have to wait for for half of the add-ons to get updated, argh.
While the passwords are stored up in the cloud, only on the computer that have the proper credentials can decrypt them. Not even those as Lastpass can decrypt them so never forget your master password. And it does not require a constant connection to the internet to work.

Have you tried the “Nightly Tester Tools” toolbar? If that one works in FF4, you should hopefully be able “force” the Roboform 6 toolbar to work with FF4.

Has anyone had any success with this?

I’ve had a little luck - it doesn’t work smoothly, but I have it working. You need to install the adapter posted about halfway down this page: Firefox Password Manager, FF Form Filler, Firefox Password Management | RoboForm for Firefox. It’s a download named roboform-firefox-3-4-frozen.xpi.

Now that I have it, when I log into FF, I see the RF toolbar button, but none of the usual menu elements that are there like Logins, Save, Generate, etc. If you click the RF button, it takes you to the page with the adapter download.

After I use FF for a while and log into a site or two, the full toolbar just shows up and I can use it normally. I haven’t yet been able to identify what event triggers it, but it does happen, and usually pretty early in the day.

I also started keeping the RF icon in my system tray so I have another option.

Good luck - let us know how it goes.


I’d go one further. Not only is it “rude and bad business”, in my view, it is borderline criminal fraud.
This is a breach of contract, and just plain slime-bag ethics.

The creators of Roboform should be sued for their unethical behavior.

At a minimum, out of principal, I certainly will NOT pay for v7, or EVER purchase one of their products again. The only way they get away with kidnapping your date is when people pay the ransom.

This is little better than infecting you with a virus, which they fix (for a price):shifty:

I am a heavy user, with nearly 500 shortcuts / password stored on USB in Roboform 6. I was having issues with Roboform 6, including their sneaky “Update” process that installed v7, without telling me it would not use my existing PAID license, and that I had to pay for their “Update”. This nearly destroyed my v6 installation (it was backed up, of course).
Then, as you mention, Firefox 4 completely broke the Roboform 6 toolbar, and Roborm will not fix this, in spite of having taken my money.

I will be moving to “Lastpass” and XMarks" for the same functionality, for less money. The XMarks free version, along with the Firefox Session Manager and Synch process should work fine for shortcuts (much better than Roboform), then I’ll probably pay the $12 for premium Lastpass, and place it on my Roboform 2Go thumb drive.
This will remind me to trash the name / behavior of Roboform at every opportunity.
Roboform can KMA.
I hope other Firefox 4 / Robofom 6 users do the same :mad:

I’d like to hear what and why you choose for your next solution. I’m not crazy about a solution that stores my info in the cloud - I don’t feel comfortable with the security of it, and don’t want to be dependent on someone else’s server - I want this data local.

Choosing a new password tool is frustrating. I don’t have a very deep understanding of security, but I know it’s important and I have a ton of client data that I’m obsessive about keeping secure. I resent having to spend the time on this.

The data does reside locally on your computer every bit of it. It just syncs up to the internet so you can sync it up with multiple computers or devices (Or for automatic backups).

The data that is sent up to the server is fully encrypted with AES. only you would have the key to decrypt this data from the server, Lastpass is never under any circumstance given your password which is part of your encryption key. It uses a different means of authenticating and associating your accound with the data.

And if you choose not to use Lastpass any longer, you can use the export function in the browser to decrypt and export your passwords to what ever form you please. You are never tied to Lastpass.

I recommend to at least give it a try.

I came upon this site and your post looking for a solution to this issue. I’m actively working at the solution right now. I did a cursory investigation of Lastpass. it does seem secure and has the advantage of accepting imports of Roboform data. I don’t like the new business model some have adopted of annual subscriptions, as it leaves you open to ever escalating fees. I’d like to see a non-profit, maintained, ethical, permanent solution (as permanent as anything can be).
As you metioned, we have better things to do with out time than spending days ransoming and rescuing our critical data.
I’m still trying to make Roboform v6 work with FF 4 and am trying the earlier suggestion of using the (beta?) roboform-firefox-3-4-frozen.xpl file. I’ve downloaded this file but: Frankly, I’m confused. How is this file used / installed? Is it used as an “Add-on” installation?
I’ve used the lame toolbar Roboform has for Google Chrome. This is no solution. It’s one of the reasons I rarely use Chrome.

Based on early reviews, it looks like FF 4 is faster than Chrome in most functions, while using about 1/3 as much memory. I occasionally use 1GB Netbooks, and have a lightweight HTPC where this is an issue.

Maybe I’m just thick today but: The information/ instructions on the Roboform site, under “Additional Full RoboForm Toolbar Information”, seem as clear as mud. They seem to be suggesting you uninstall the Roboform Toolbar from FF4, then re-install Roboform 6, with specific settings regarding the “Adapter”.
The Author embeds the xpl file within this section, while not clarifying its use, or how it relates to re-installing v6 after updating to FF v4?

Any further info on adapting RF v6 to FF v4 (including how to use the xpl file) would be appreciated.

I just installed FF 4 on my desktop a couple hours ago and, as an (un?)related issue, FF 4 has been throwing script timeout errors.
I have to stop the script, or FF4 will not open. Input appreciated.

I’m not happy that Roboform has decided to charge an annual fee. I’m not surprised either as they probably are looking for ways to have a regular revenue stream.

I’ve determined I’ll have to live in the past. Firefox 3 and Roboform 6.

I was a strong advocate for Thunderbird as an e-mail client. However when they went to TB3 and eliminated the search in the upper left corner subject, e-mail, etc. I decided that feature was too important to give up. I use it daily.

At some point, enough is enough! At some point, a decision must be made about what I am going to participate in. I think I’ve come to the point that I need basic functionality and not necessarily the latest and greatest. I will have to resist the “enhancement creep” factor.

At some point I may give in. However, right now is not the time. Putting income and expenses in a spread sheet and making determinations about where limited $$ goes, this also has an influence on my behavior.

All of this to say that I do not expect Roboform 6 to work in FF4. FF4 is on my wife’s computer but it does not have Roboform.

When I purchased a laptop computer, it came with Vista. Vista was replaced with XP to maintain more compatibility between my desktop and laptop. I do not regret that decision several years later.

I’m retired, stubborn, don’t like to be pushed and can be an SOB if necessary.

Here are the steps to get it working - it works fine for me and I hope you all have the same success

1. Install Roboform 7.2.7
2. Copy folder "c:\\Program Files\\Siber Systems\\AI RoboForm\\Firefox\\" to another location
3. Install Roboform 6.10.2 -dont untick option to install adapter for firefox
4. Replace "c:\\Program Files\\Siber Systems\\AI RoboForm\\Firefox\\" with your copy from 7.2.7 version
now you should have working 6.10.2 roboform with latest adapter from 7.2.7

Hope this helps all of you roboform users.

Thanks for the suggestion, but it didn’t work for me. :frowning:

I take that back. It didn’t work at first, but does now. Hm.

@ mudsharky

Your suggestion worked great for me - thanks for posting it. Really frosts my cake when Roboform tries to hit up their paid customers AGAIN for nothing more than a release upgrade (this is especially true when I don’t use any of the “new-fangled” platforms their version 7 includes … and that they tried to use to justify the “New” license fee).


That’s what alot of banks, government agencies, corporations, etc, though before they got hacked and compromised…just cause they wanted convenience.

Well, it was convenient alright…but turned out it was also convenient for crooks as well since security technology gets passed around the underworld.

Betcha this whole “cloud” storage thing is gonna come back and bite everyone in the backside someday. It’s too easy for something like this to be taken away or manipulated for sinister purposes.

Personally, I’ll keep my data locally…thank ya!

Then it is a good thing, LastPass only stores the encrypted data. They don’t even have your password or encryption key on storage. Your master password LastPass uses never leaves your computer along with the encryption key. The only thing they have is the encrypted data and a unique hash to identify you and associate you with the data in there system.

So unless you used a super weak password like “a” your data is safe.

Kim thanks very much for the info about Firefox Password Manager, FF Form Filler, Firefox Password Management | RoboForm for Firefox
I had been trying to sort out the problem for weeks and sent several emails to Roboform but no luck.
implemented your advice and bingo roboform tool appeared with every element showing
Cheers for that advice:)

This works for me for firefox 4 but of course there is now a firefox 5. Has anyone tried roboform 6 with firefox 5?

No don’t even go there, loaded both and its totally screwed things up lost Google toolbar and Roboform. When I tried to load Google again it said that Firefox 5 doesn’t support it. Firefox have not replied to my question WHY!!!