Error: Your host needs to disable magic_quotes_gpc to run this version of Joomla!

I have made 1 site using Joomla 3.0, I have upload the site folder on my host server.
Problem is I get below error message when I try to login administrator panel. Error is something like this:
Error: Your host needs to disable magic_quotes_gpc to run this version of Joomla!

On my Cpanel Softaculous AppsInstaller, there is joomla 2.5.

I can open all my pages, and can also login to Administrator panel, but I am trying to remove index.php from the url, and to do that I have taken below steps
1: rename htaccess.txt to .htaccess
2: In joomla administrator, cpanel, global configuration, In SEO settiings I have said “YES” to Use URL rewriting

If I do above settings I cant open my joonla website on my host server except home page.

Please can anyone help me to allow to remove this “index.php” from the url using joomla 3.0

Many thanks In Advance

The solution seems clear: disable magic quotes on your server:
Or ask your hoster to do so.

It should be disabled anyway. From the php website:

This feature has been DEPRECATED as of PHP 5.3.0 and REMOVED as of PHP 5.4.0.

You might just ask your host to upgrade their PHP version :wink:

Many thanks for instant reply

On my server I cant find the php.ini file
thank you

i asked my line manager to ask our host to upgrade php version, he said i cando myself from cpanel, can you please tell me how can I upgrade php from cpanel?

thank you so much

Did you open your cpanel?
I guess you’ll have to look for something like ‘Upgrade PHP’ or ‘Manage PHP’ or ‘PHP version’.
Just check out a couple of cpanel options and see if you can find it.

I checked my cPanel, there is no such option regarding Upgrade PHP/MAnage PHP/PHP version

Try PHP configuration

there is no such buttons/links to change or upgrade anything

Then you’d better ask your line manager. He knows.

Yes… i will now,
But Thank you so much for your help through out