Emails showing on one client but not the other

I’m using my hosting email address set on two clients on two different pcs. I just foud out some of the inbound mail is missing in mine.
Doing a couple of try I found out just inbound mails I checked first show up on my client. The other whorks regularly.

Any Idea?

Can you describe the issue a bit more clearly. For example is the following true:

An email is sent to

PC 1, using a Mail Client receives the Email
PC 2, using a different Mail Client does not receive the Email

Is that correct?


Okay, first question. How did you setup each client, using POP3 or IMAP?

POP3 will download the email from the server and in most cases, then removes that email from the email server. So if Client 1 downloads the email first, it will remove it from the email server and Client 2 has nothing to download.

Likewise, Client 2 could download the email first, remove it, and Client 1 can’t download it now.

You technically can change the settings for POP3 to not remove the email from the server. However, many would claim that isn’t a good way to handle this situation and to instead use IMAP.

IMAP keeps all of your emails on the email server. Each client simply shows what is sitting on the email server by sending a request and asking for the emails. As you select each email, it sends a subsequent request to temporarily download it and show it within the client. If you delete an email on one client, it will be deleted from the second client automatically.

They’re POP3. I thought that too but one of the client (the one working properly) keep downloading messages even after those have beed downloaded before from the other client.

Maybe one client is set to not delete the emails and the other one is?

In that scenario, if the client that does delete the emails from the server gets the email first, the second client won’t get it. But if the second client gets the email first, and doesn’t delete it, then when the first client gets the email, it will delete it (so both get it).

You were right :smile: It seems working now. Thanks anyway!