Eclipse 3.6.0 All In One -> subclipse not installing

I tried installing subclipse through the “Help->Install New Software” and the URL is but it fails every time. It shows following items

  1. CollabNet Merge Client 3.0.8
  2. Subclipse (Required) 1.8.8
  3. Subversion Integration for Mylyn 3.x (Optional) 3.0.0
  4. Subversion Client Adapter (required) 1.8.2
  5. Subversion JavaHL
  6. Subversion Revision Graph

I tried them one by one and only the following could be installed, other four failed:

  1. Subversion Client Adapter (required) 1.8.2
  2. Subversion JavaHL

One of the errors I get is:

An error occurred while collecting items to be installed session context was:(profile=epp.package.php, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=). Comparison method violates its general contract!
My environment is as follows:

Is there anything I’m doing wrong?

I need at least Subclipse 1.8.8 and CollabNet Merge Client 3.0.8 also in addition to Subversion Client Adapter 1.8.2, Subversion JavaHL that I could install.


What version of java are you running?

There might be compatibility issues with java version 7u3 and eclipse 3.6. Either try upgrading to eclipse 3.7 or downgrade to java version 6u31.

Thanks Force.
I checked my control panel and I see 3 entries there:
Java 6 update 31,
Java 7 Update 3,
Java 7 Update 3 (64-bit)

Is this the issue that I’m having multiple of them?

According to the bug report, the fix appears to be to either upgrade to the latest version of eclipse 3.7, or uninstall java 7.

Thanks a ton, I uninstalled all Java Instances and just installed JRE 6 Update 32, it fixed the issue. Fantastic, precise solution.

Just one last query, a link to the tutorial / good reference about how to use/connect SVN through the Eclipse would be a great help, though I’ll also Google but a link from expert will be more useful. I’m using Eclipse for PHP development.

How do I mark #4, your response as the solution?