Drupal Views issue

I’m trying to use Drupal’s “Views” module to output 2 unique views for Stories. Basically, it’s like this: I’ve left my theme’s output for the latest story as-is where I have it set to display only 1 post. However, I’ve used Views to display the 2nd-to-last and 3rd-to-last story created where I have these last 2 inline with each other. So far, on my localhost, it looks great! :slight_smile:

BUT… When I transfer everything to our production server, it seems to have problems displaying the posts (stories) in chronological order: it only displays 2 stories, and keeps only these stories–it doesn’t incrementally swap them in accordance to chronology.

I’m not going to ask anyone here about how to fix this because I realize that it will have probably a lot of work involved. Instead, I was hoping that someone familiar with this module and Drupal in general might be able to provide some insight into HOW to pinpoint the issue altogether.

Anyone have any ideas? I’m really banging my head about this…

Never-mind, everyone. I’m not entirely sure what caused it from the beginning, but I dumped the database and reinstalled Drupal and the Views module… Now it’s working.

Logically-speaking, my theory is that this has something to do with not having enough stories to populate views that are designated with the “offset” attribute. You see, when I created these views, I guess I needed to have enough stories within the database for the queries to have something to work with. Since there were none where they were needed, it bombed. Makes me wonder if others have experienced this…


Views is amazing module. Its on of those modules that you just cross your fingers and hope everything works though, lol. There is just so much vodoo going on its almost impossible to debug.

That would explain my inability to find help with it! :lol:

I’ve been doing everything from sending smoke signals to the IRC groups to posting on their forums to absolutely no avail. Not sure what I’ll do. :injured:

Yep, one of my major caveats with drupal and module development in general is its a slop-fest with horrible documentation. Everything works perfectly until it doesn’t work at all. Its a powerful sloppy mess though, more powerful and flexible than all open source content management frameworks available that I have experienced. Panels, Views, CCK(now part of d7 core),webform, imagecache(part of d7 core) make for one amazing system, that is for sure.

Yeah, I know where you’re coming from because it’s having issues again. :frowning:

I’m thinking this must be a server issue now…

Perhaps you have some sort of opcode or query caching on your prod server? Either could easily cause the problems you are talking about.

Here’s the MySQL stuff from phpinfo():

MySQL Support enabled
Active Persistent Links 0
Active Links 0
Client API version 5.1.41
MYSQL_SOCKET /blah/mysqld.sock
MYSQL_INCLUDE -I/blah/mysql
MYSQL_LIBS -L/blah -lmysqlclient_r

Directive Local Value Master Value
mysql.allow_local_infile On On
mysql.allow_persistent On On
mysql.connect_timeout 60 60
mysql.default_host no value no value
mysql.default_password no value no value
mysql.default_port no value no value
mysql.default_socket /blah/mysqld.sock /blah/mysqld.sock
mysql.default_user no value no value
mysql.max_links Unlimited Unlimited
mysql.max_persistent Unlimited Unlimited
mysql.trace_mode Off Off

And here’s the stuff from the PHP-specific section…:

PHP Version 5.3.2-1ubuntu4.7

Directive Local Value Master Value
allow_call_time_pass_reference On On
allow_url_fopen On On
allow_url_include Off Off
always_populate_raw_post_data Off Off
arg_separator.input & &
arg_separator.output & &
asp_tags Off Off
auto_append_file no value no value
auto_globals_jit On On
auto_prepend_file no value no value
browscap no value no value
default_charset no value no value
default_mimetype text/html text/html
define_syslog_variables Off Off
disable_classes no value no value
disable_functions no value no value
display_errors On On
display_startup_errors Off Off
doc_root no value no value
docref_ext no value no value
docref_root no value no value
enable_dl Off Off
error_append_string no value no value
error_log no value no value
error_prepend_string no value no value
error_reporting 30711 30711
exit_on_timeout Off Off
expose_php On On
extension_dir /blah/php5/20090626+lfs /blah/php5/20090626+lfs
file_uploads On On
highlight.bg #FFFFFF #FFFFFF
highlight.comment #FF8000 #FF8000
highlight.default #0000BB #0000BB
highlight.html #000000 #000000
highlight.keyword #007700 #007700
highlight.string #DD0000 #DD0000
html_errors On On
ignore_repeated_errors Off Off
ignore_repeated_source Off Off
ignore_user_abort Off Off
implicit_flush Off Off
include_path .:/blah/pear .:/blah/pear
log_errors Off Off
log_errors_max_len 1024 1024
magic_quotes_gpc Off Off
magic_quotes_runtime Off Off
magic_quotes_sybase Off Off
mail.add_x_header Off Off
mail.force_extra_parameters no value no value
mail.log no value no value
max_execution_time 30 30
max_file_uploads 20 20
max_input_nesting_level 64 64
max_input_time 60 60
memory_limit 16M 16M
open_basedir no value no value
output_buffering no value no value
output_handler no value no value
post_max_size 8M 8M
precision 12 12
realpath_cache_size 16K 16K
realpath_cache_ttl 120 120
register_argc_argv On On
register_globals Off Off
register_long_arrays On On
report_memleaks On On
report_zend_debug On On
request_order no value no value
safe_mode Off Off
safe_mode_exec_dir no value no value
safe_mode_gid Off Off
safe_mode_include_dir no value no value
sendmail_from no value no value
sendmail_path /blah/sendmail -t -i /blah/sendmail -t -i
serialize_precision 100 100
short_open_tag On On
SMTP localhost localhost
smtp_port 25 25
sql.safe_mode Off Off
track_errors Off Off
unserialize_callback_func no value no value
upload_max_filesize 2M 2M
upload_tmp_dir /blah/uploads /blah/uploads
user_dir no value no value
user_ini.cache_ttl 300 300
user_ini.filename .user.ini .user.ini
variables_order EGPCS EGPCS
xmlrpc_error_number 0 0
xmlrpc_errors Off Off
y2k_compliance On On
zend.enable_gc On On

I don’t think there’s any caching issues going on with this. That said, I’m still wondering if this somehow has to do with file permissions because it needed some permission tweaks during the first-time installation. Now, however (even after having reinstalled everything once), it has never output any issues pertaining to permissions.

This is really frustrating. It works perfectly fine on localhost, but on prod, it’s just not updating the stories… I’m about to pull my hair out! :confused:

FINALLY found out what was going on… And yes, it’s my fault. Damn! ;.)

Anyway, it had to do with how I setup the sorting in combination to the filters… That’s all. Ha.