Drop database error

Just started working through php and mysql novice to ninja 5. second chapter, MYSQL i have set up the servers on my computer and so on. go in to PHPmyadmin and try to drop “test” database. when i try i get this error any ideas?

SQL query: Edit


MySQL said:

#1010 - Error dropping database (can’t rmdir ‘.\ est\’, errno: 17)

A search on this error number turned up this.

If your Mysql version number matches one of those reported, then one of the workarounds might work for you.

thanks for the link, had a look and tbh i havent got a clue what it is saying. if you know, could you explain in a way a person not knowing MYSQL too much could unnderstand?

Thanks again for the quick reply

heres the suggested fix (taken from cups link) incase anyone else knows?

Suggested fix:
Solution 1:
Remove .empty in mysql_rm_db (sql/sql_db.cc)

Solution 2:
Use db.opt as DUMMY_FILE instead of .empty
AND remove .empty on upgrade.

managed it, went into directy and deleted .empty file tried to drop it again with phpmyadmin and worked. works a treat.

incase anyone has this problem in future.

/xampp/mysql/data/test and delete .empty

thanks again

Good on you for posting the fix and confirming that it works!