Divider problem with wordpress theme on comments page

Hello, does anyone know how I might correct the width of the 1px divider on the comments page of my site? I changed it to 100% and that didn’t quite do the trick.

Any ideas? website: h**p://www.ioimi.com/offered-example/


What does “correct” mean? And which divider? Not quite clear what you mean.

Hello, thanks for your reply!

The text box should be in line with the 1px divider above.

There are currently no examples on the page (the white text box isn’t there. Perhaps post a comment so we can see what’s going on.

It doesn’t matter that there are no comments shown, that is deliberate.

What matters is that the reply text box is the same width as everything else, as demonstrated in the image below.

Yes, but unless we can see it live and dig into the code that creates it, we can’t see what’s making it that wide. A live page allows us to see the underlying code. It’s possible that the text box is set to width: 100% but also has left and right padding, which makes it more that 100% in total width. But that’s just a guess.

Okay, so I need to enable displaying of comments?

Actually, I checked your CSS and yep, that’s the cause. You have

#commentform .input, #commentform .textarea {
	margin:0 5px 0 0; 
        padding:4px [COLOR="Red"]6px[/COLOR];
	width:200px; height:auto;
	border:1px solid #d3d3d3;
	font:0.92em Georgia, "Times New Roman", Times, serif; color:#666666;

#commentform .textarea {
	font:0.97em Georgia, "Times New Roman", Times, serif;

Try changing width: 100% to something like width: 594px (you may have to adjust that by a pixel or two.)

Hope that helps. :slight_smile:

Wow, thanks for that!

I changed it to 550px, I THINK that is right. What about you?

I settled for 548px!

This thread is solved, please close.

I just did a quick calculation based on the container width and its padding. But I find textarea widths a bit unpredictable, so I’m not surprised if it needs a bit more shaved off. You’ll need to decide, as I can’t see the results.

EDIT: O, didn’t see your next post. Great, glad it’s fixed. :slight_smile: