Distort / Perspective Menu Choices "Grayed" Out?

I fool around with Photoshop a bit, but am not very proficient.

I have some text I am trying to distort / change the perspective of. What I want to do is have the text curved a bit, like in a quarter moon perspective.

For some reason, the distort and perspective menu choices are grayed out on the transform menu.

Any idea why this might be or what I can do to resolve it?

Thanks very much.

[FONT=“Georgia”]You just answered your own question.

Text layers cannot be distorted/perspectived.

You’ll have to right-click on the text layer and choose “rasterize type” to convert the layer to pixels. You’d then be able to use those transformations.

[/FONT]

Thanks Shaun. Much appreciated.

Needless to say, that works, but I still can’t figure out how to distort the text in a horizontal 1/4 moon type configuration?

Can you offer some advice on that?

[FONT=“Georgia”]Sure.

For those types of effects you’d need to create a path first, then type onto it.

“Paths” in Photoshop refer to vector (mathematical) shapes/lines and can be created in a few ways… Using the Pen Tool is one. Photoshop shapes are another.

Aside: On the Layers window, click the Paths tab to see all existing work-paths in your Photoshop document.

For a perfect “half-moon” you can use the Ellipse Tool to make a circle. Check the “Paths” button at the top tool bar to prevent the shape from being filled.

Next you’re choosing the Type Tool and clicking onto the path itself (you’d see the T icon change from having a box around it to having a line below).

After that it’s pretty straight forward… type away to your heart’s content.

See this thread for some tips… it’s about typing onto a path in Illustrator, but there are some basic similarities.

Play with it a little too and you’ll figure out the rest.

[/FONT]

Thanks again. I have created the elipse and have clicked on the Path tab in the layer window.

However, I still get horizontal type and never see the T icon change to having a line below it, nor does the text I type follow the path.

I must be missing something…

_

[FONT=“Georgia”]Dude !!

ARGH !!

Okay here’s my final attempt at demonstrating this.

Click the attachment below to download a tiny screen-recording of what I’m doing.

See ?.. Once you have the path made, all you need to do is choose the Type Tool and click on the path. That’s it.

[/FONT]

[FONT=“Georgia”]Maybe I shouldn’t have phrased that in that way. Maybe that’s what’s throwing you off.

I’m talking about the cursor.

The sort of T shaped cursor usually has a box around it.

When you bring the cursor near to a path the cursor changes and then gets an angled line below it.

When you see that happen, click, and you’d be able to type on the path.

[/FONT]

I’m sorry if i’m not following this thread properly but would not the option desired reside in the Warped text option??

Or am I just way off base?

macarthur, Thanks for the tip. I had not used the warped text option, but I can get it to work and it solves my problem.

Shaun, I have not been able to open your zip file yet, but I can see that your technique allows much greater control and can be used in more specific situations.

I follow your technique to the letter, draw the path, choose the Path tab of the Layer window, and move my cursor around on the pallette. I see the T and the square cursor, but no matter where I move the cursor I never get the change in the cursor and thus cannot type onto the path.

Weird.

[FONT=“Georgia”]I don’t know, dude.

I have no idea why it’s not working for you.

I also don’t know how else to describe it to you.

If you got macarthur’s thing to work just use that. In fact that’s a really nice tip because I never noticed that feature before but it has some very cool options. :tup:

All the best.

[/FONT]

@Shaun, Thanks again for the all help. Perhaps my older version of PhotoShop is the culprit here?

Much appreciate your help, however!