Disabling IE compatibility mode once and for all!

Hi All

I’m going round the bend with regard to this problem!!!

I have a https site hosted on a mainstream host, developed in classic asp and is used by schools.

If I look at my site using IE and I’m outside of schools then it shows up as expected. In other words I need it to run in IE9 or above, which should be fine as nearly all school machines are running Win7 and therefore automatically have IE9 or above.

My problem is that some of them are fixed to run in IE compatibility mode so the site looks pants.

I’ve tried the META tag in the <HEAD>.

I’ve tried the add a http header option.

I’ve tried (and my current setup) the web config entry.

None of them seem to make any diff.

My sites not an intranet site and 99% of them are on Win7 machines, but I can’t get the ruddy browser to run in the version it is.

I don’t want to cop out and tell them to use a different browser, so does anybody know what I’m doing wrong or what I can check??


I presume you mean this:

<meta content="IE=edge" http-equiv="X-UA-Compatible">

I believe that has to be the first element after the opening <head> tag; could that have been the problem with it not working?

1 Like

Hi TechnoBear

Many thanks for the speedie reply.

Yes, I used this as the first entry after

Is there anything else I should change or can I test it somehow to find out why a schools-based browser has decided to go into IE ‘dog years’ mode?

Could you give us the website where you are currently having those problems? I assume you have a valid doctype?

Please give us the website and we can advise from there. @TechnoBear should have been spot on with her advice.

I went for the web.config:

<?xml version="1.0" encoding="UTF-8"?>
        <add name="X-UA-Compatible" value="IE=edge" />
      <httpErrors errorMode="DetailedLocalOnly" />

As this was supposed to be ‘the’ way, but I’m still getting the issue - in plenty of laptops/desktops in school and the biggest problem is that I don’t think the user can even disable compatibility mode. It’s greyed out.

Please open up the website and give us the “view source” for the beginning of the webpage, up until the </head>.

Crikey - everybody is like lightning on here!!! :smile:

web site address is:


Could we get a login :slight_smile: ? I don’t see any meta compatibility tag on that page so I assume it’s inside the login.

Off Topic:

To post code, either put three backticks ` on a lline above your code block, and another three on a line below it, or you can use the highlight it in the editor window and use the </> button to format it.

Hi Ryan

I’ve taken the tag out of this so as not to create another ‘call’ (advised to do this) because I’m doing it in the web.config file.

Apols technobear just getting used to the site :smile:

1 Like

No need to apologise - it does take some getting used to. And posting code which then miraculously becomes invisible is just one aspect of that!

OK - I know nothing at all about ASP, but I’ve found this article, which shows slightly different syntax:


In their example, they use <add name="X-UA-Compatible" value="edge" />, rather than <add name="X-UA-Compatible" value="IE=edge" />.

They also show another method of adding it using the AddHeader method.

Hi Technobear

Many thanks for this. That setting change could be the crucial factor. I’m just rummaging through my web history to see where I got the orig web.config detail from to make sure I didn’t invent that value.

Will need to wait until schools are back in to see if this is it!!

Many thanks for all of your speedy help.

I don’t think you did, because I came across that, too, on my travels. As I say, I know nothing of ASP, so I can’t say which is right, but it seems an easy fix to try.

Let us know whether or not this solves your issue. We do have folk around who are knowledgeable in ASP, if you need more help.

Thank you. So frustrating because I can’t sit next to a machine and see this actually happening. Got to keep dropping in and pinpoint how to get round it. Don’t want to suggest another browser or dumb down the app just to accommodate that it might run in something that’s probably running like something made 5 years ago when its actually really up-to-date !!

1 Like

Let’s face it… the data may be uptodate but the app? Classic ASP? It has been dead for a number of years now and only sites that have been around forever use it.

Don’t take it as a critic. There are legit reasons for keeping Classic ASP for a website and not change it to .NET or any other language. It may be too hard to do to make it worth it. Most of the time, chage it to .NET is easy but sometimes… it is just a pain.

As with everything in web development, you have two different things to take into consideration: your end and the client’s end (in this case, the schools)

My first thought is the code itself. If the resulting code (the one received by the browser) was completely fine, it wouldn’t matter if it was sent in compatibility mode or not (glad that you’re checking the value though ;))

If you want to play with the web server configuration file and you’re not sure what’s going on, try to use a virtual machine with the same configuration and a copy of the site so you can play safely.

If you’re force to use the real one, and you’re not close, connect via VPS or, if you’re in the same network, remote conection.

And only do simple changes such as this one, that you can revert back. Because this is dangerous.

Now, if the site is well built, the web server is configured properly and everything looks fine and dandy in your end, maybe it has something to do with their end. Like maybe a proxy bit too strict in its rules, or a non-forgiving firewall. That may cause that some files may not download or other issues.

This topic was automatically closed 91 days after the last reply. New replies are no longer allowed.