Curl error thrown for http POST to /session

I installed Laravel Dusk for website testing. I tried every solution on Stackoverflow regarding this problem but nothing worked.

I need to run browser headless because I’m running tests on my Linux server.

Current version of chromedriver-linux is:

 ./vendor/laravel/dusk/bin/chromedriver-linux --v
ChromeDriver 90.0.4430.24 (4c6d850f087da467d926e8eddb76550aed655991-refs/branch-heads/4430@{#429})

Current version of Chromium is:

 chromium-browser --version --no-sandbox
Chromium 90.0.4430.93 snap

When I run Dusk I get error:

Operation timed out after 30001 milliseconds with 0 bytes received
Curl error thrown for http POST to /session with params: {"capabilities":{"firstMatch":[{"browserName":"chrome","platformName":"linux","goog:chromeOptions":{"args":["--headless","--disable-gpu","--no-sandbox"]}}]},"desiredCapabilities":{"browserName":"chrome","platform":"linux","chromeOptions":{"args":["--headless","--disable-gpu","--no-sandbox"]}}}

Is there any way to resolve this? I tried by adding arguments "--headless","--disable-gpu","--no-sandbox" but unfortunately it is not working.