Cufon Hates Me!


I’ve been working on a new website, trying to make use of “Cufon” to replace fonts. I’ve got it all working… on my computer. It doesn’t work in IE6, however, and it doesn’t work in any browser on my fiancée’s computer (tested Firefox 3.0.16 & IE7… might have been IE8).

I’ve tried a few different ways of coding this, but nothing is changing how it renders in IE6.

I’ve spent about 3 days focusing on this issue, doing searches, looking at example code, making changes… nothing is getting me any closer, so I figure it’s time to pass it off to the community and see if some guru can point me to the path of enlightenment.

Any Cufon ninjas out there?



P.S. - You’ll find a link to my code at: (Thanks for taking a look).

I have used Cufon, and I have a one-word recommendation for you. Run!

Cufon and its cousin, Typeface.js, are, in my experience, nothing but an awkward, heavy bag of trouble and pain compared to @font-face (as brilliantly implemented by the free FontSquirrel). By serving four different versions of a font, FS manages to support over 95% of current browsers without resorting to Javascript!

I’ve seen plenty of companies and individuals using Cufon perfectly… just can’t seem to duplicate it myself.

I think I’d still prefer to go the Cufon route for now, but if I can’t get this thing solved then I may consider using FontSquirrel. Thanks for the suggestion.

Anybody want to take a stab at it???

Simple issue… wasn’t anything wrong with Cufon at all. I didn’t include jQuery!!! Oh my G*d!!! 3 Days on this. Not sure why Firebug didn’t pick this up. Oh well, onwards and upwards.

Have you considered using google fonts instead?