cPanel stops sending e-mails to a Gmail account when it is updaded


I have a website hosted on a webhosting on a shared server with cPanel access.
The website has a “contact us” form to fill for us to receive an e-mail using PHPMailer.
Our e-mails are not created in cPanel, they are Google Apps (Gmail).

All works perfect until an automatic update is made in cPanel.
When it happens, the MX record is set to localdomain instead of Google servers, and we stop receiving e-mails.

How could we prevent this situation?

Thanks a lot!!!

Have you talked to your web host about it? That obviously shouldn’t happen.

Yes. This was the answer they gave me. They said this configuration is changed with each new cPanel automatic update.

That seems a bit silly to me, but I don’t know much about this stuff. CPanel has been updated on my server quite a few times and the MX records haven’t been changed (and I’m using Apps like you). Can you turn off auto updating?

I guess I can, but updates are normally necessary so I wouldn’t like to lose them.

Yes, fair enough. I can’t believe your host is satisfied with that lame answer they gave you.