Could not bind to address 0.0.0.0:443

Hey, all!

I’m (regrettably) new to apache, and I have installed it on Ubuntu Hardy.

Whenever I attempt to start the web server, I get the following error

* Starting web server apache2
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
   ...fail!

I have tried to research this but to no avail. If anyone has a suggestion, I’d love to hear it.

I have full permissions on the machine and can rebuild the entire thing if necessary (we just set it up a day or so ago). Have at it!

Any help would be greatly appreciated. I’ll provide as much information as possible as soon as I know what to look for. Thanks in advance!

sean,

0.0.0.0 is not a valid IP address. Localhost is 127.0.0.1 but, if you’re using it for other than a test machine, you must use your (external) IP address.

Regards,

DK

Hey david,

Thanks for the response. I know it’s not a valid IP. I guess part of my question was where to find this to change it.

As an update, I was able to find the conf file that referenced a same command twice (dunno why, as I’d never edited it). When I fixed that, the problem was solved and I’m good to go.

Thanks for offering your help, though!

sean,

I’m on a WinDoze box where the answer is in the httpd.conf. Search your .conf file for 0.0.0.0 and change that in every instance (127.0.0.1 for a local test server) and that should resolve the IP address problem (upon Apache restart).

Regards,

DK

I’m getting the same error, but I don’t see a ports.conf file. When SSL was installed, the line “Listen: 441” was entered, as well our domain name:441. I get the following error that references port 443.

Starting httpd: (98)Address already in use: make_sock: could not bind to address [::]:443
(98)Address already in use: make_sock: could not bind to address 0.0.0.0:443
no listening sockets available, shutting down
Unable to open logs
[FAILED]

Is there a way around this? If I leave the 441 it works fine. If I change the 441 to 443 it chokes.

sean,

It’s been a LONG time!

IMHO, you’d be better off by UNinstalling then reinstalling and using 127.0.0.1 and port 80 for http and port 443 for https. Once you get off on the right foot, everything else becomes simple.

Regards,

DK

Try to run

grep :443 /etc/apache2 -R
grep Listen /etc/apache2 -R

to see if you can find the problem that way.

This might occur if any other process is already using Port 443.
Run the following to find the process:


netstat -plan | grep :443

This is what I get after running that command

tcp 0 0 :::443 :::* LISTEN 23376/httpd

Seems secure httpd/apache service is already running on port 443.
You could see a similar result for port 80 for normal httpd/apache.

Try restarting apache using the following command:


service httpd restart
OR
/etc/init.d/httpd restart

in some systems there are seperate apache packages for and without ssl, in some scenarios, debian for one, the seperate servers may both be running, generally you may find apache and apache-ssl in /etc/init.d to start or stop each as required