contentEditable content going over page limits

If you type a long text after 2 enter for exemple the text will go beyound the container limits.

It should have the same behaviour as this page when it reach the content with limit:

tried to figure out why my text is overflowing beyound its limits .

Plz help .


I’m testing it with Chrome and can’t reproduce the effect. It seems to be working fine. What browser are you using?

That said, I have experienced similar things with contentEditable in the past. I got around it by messing about with margins and changing the container size slightly.

I got the problem in IE7,IE8 , FF 7.0.1,. It seems to be worcking fine with chrome at least.

I’ll already tried that :I. I will look at chrome(15.0.874.106) to see whant it is doing differently.

lol Nevermind its working , if i typed ffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffffff it would not work but everything is ok if i add a space :).

Anyway no word that long exist XD.

Guess i was tired XD.

I think setting the word-wrap property to break-word will protect against the problem. I did that in Firefox and the issue went away. I would imagine it would work the same in IE, though I haven’t tested it. Granted, it is a bit of an edge case, but it’s also a trivial fix.