Content breaks out of design?

Hi, I am developing a Tumblr theme and I am having issues with the content breaking out, below my design?

Any ideas why this might be happening?

Thanks

Your content from the iframe down isn’t contained in your container div. You may have inadvertently closed it off too soon.

Thanks for having a look, I didnt use an iframe? Maybe Tumblr creates one in my code?

I have 4 errors and 1 warning when I validate, but they look related to the tumblr code?
The content still breaks out?

	
	
	
 
 	<div id="thefooter"> 
 	<p>footer</p> 	
 	</div> 
</div></div> 
<!-- BEGIN TUMBLR CODE --><iframe src="http://www.tumblr.com/dashboard/iframe?src=http%3A%2F%2Fcodetestingthemes.tumblr.com%2F" scrolling="no" width="324" height="25" frameborder="0" style="position:absolute; z-index:1337; top:0px; right:0px; border:0px; background-color:transparent; overflow:hidden;" id="tumblr_controls"></iframe><!--[if IE]><script type="text/javascript">document.getElementById('tumblr_controls').allowTransparency=true;</script><![endif]--><script type="text/javascript">_qoptions={qacct:"p-19UtqE8ngoZbM"};</script><script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script><noscript><img src="http://pixel.quantserve.com/pixel/p-19UtqE8ngoZbM.gif" style="display:none; border-width:0px; height:1px; width:1px;" alt=""/></noscript><!-- END TUMBLR CODE --></body> 
</html> 
 
	
	
	
	
	
	
	
	
	
	
	
	
	<div class="post"> 
		<div class="quote"> 
		
			<div class="date"> 
				<p>9 April 2010</p> 
			</div> 
			
			
			


There is a closing html and closing body tag halfway through your markup, and then another one a bit further down

	
 
 	<div id="thefooter"> 
 	<p>footer</p> 	
 	</div> 
</div></div> 
<!-- BEGIN TUMBLR CODE --><iframe src="http://www.tumblr.com/dashboard/iframe?src=http%3A%2F%2Fcodetestingthemes.tumblr.com%2F" scrolling="no" width="324" height="25" frameborder="0" style="position:absolute; z-index:1337; top:0px; right:0px; border:0px; background-color:transparent; overflow:hidden;" id="tumblr_controls"></iframe><!--[if IE]><script type="text/javascript">document.getElementById('tumblr_controls').allowTransparency=true;</script><![endif]--><script type="text/javascript">_qoptions={qacct:"p-19UtqE8ngoZbM"};</script><script type="text/javascript" src="http://edge.quantserve.com/quant.js"></script><noscript><img src="http://pixel.quantserve.com/pixel/p-19UtqE8ngoZbM.gif" style="display:none; border-width:0px; height:1px; width:1px;" alt=""/></noscript><!-- END TUMBLR CODE --></body> 
</html> 
 
	
	
	
	
		<div class="post"> 
			<div class="text"> 
			
				<h2> <a href="http://codetestingthemes.tumblr.com/post/508106801/first-text-post">First Text Post</a></h2> 
				
					
			<div class="date"> 
			<p>9 April 2010</p> 
			</div> 

Remove the all </body></html> from your code apart from the ones at the very end of your markup.

Hope that helps in someway

Thanks for looking at the code, but that seems to be generated by tumblr.
http://pastie.org/912189
That is the actual code I am using for the theme and the source is what tumblr does with it.

No problem, I tried to look at the code @ http://pastie.org/912189 but the connection times out as it takes to long to load.

I guess you need to tell us how you are developing this theme. It’s not clear what you are doing and what Tumblr is doing. What aspects to you have control over?

I seem to have fixed the issue thanks everyone.

Looks like it was the tumblr markup then.