Connection Problem with site, but not PHPMyAdmin

I have having some issues with connections, but only with a new user in mysql.

I have a master MySQL user (not root, but almost as powerful) that I use when developing a new database and website, then when it get’s close to production time - I create a new user with limited credentials before the site goes live.

This has worked for years in the past, but now I am having problems. I have a new server running RHEL 5.x, PHP 5.2.12, and MySQL 5.0.x (latest stable version).

For some reason when I create the new user (and flush the privilages) the connections fail. If I go back to my master settings, they work. To complicate matters, MySQL Admin works fine with the new user. It will connect, and only show the database the new user is assigned to. I can add/edit/delete records without a problem. At least with that - I know MySQL has flushed the privilages and re-loaded. But my sites cannot seem to connect!

Does anybody have any ideas what to look for? I believe PHPMyAdmin uses MySQLi, yet I develop in Dreamweaver - so I end up using MySQL pConnect most of the time. Is there an issue with pConnect (by the way, I have tried just using connect as well)? Do connections get cached?

Any help would be appreciated.

This problem was solved!
It turns out the password of the new user was using an * character, but was not enclosed in quotes when it was entered into the DB. I never realized this would cause grief when the script tried to access the DB.

For some reason - PHPMyAdmin used it just fine.

From SSH - I reset the password, but this time enlosed it in quotes. It now works perfectly!