Coldfusion: Strange <layoutarea> hehavior?

I am using the <cflayout> and <cflayoutarea> combination on several pages in one of mine sites. Everything works fine (off-line) until I upload the files. Then when submitting the forms inside the <cflayout> and <cflayoutarea> I get the following error:

Error replacing HTML, element not found: cf_layoutareacf_layoutarea1332489330941

Does anyone arround have experienced the same problems, and if so how can I solve this? Here is the markup from the page:


<cflayout type="hbox">
	<cflayoutarea>
    <cfform name="testForm" action="layout_action.cfm">
        Name: <cfinput type="text" name="name" value=""><br />
        <cfinput type="submit" name="submit" value="submit">
    </cfform>
	</cflayoutarea>
</cflayout>

and layout_action.cfm


<cfif structKeyExists( Form, "name" )>
Hello <cfoutput>#Form.name#</cfoutput>
</cfif>

These are just a test pages and there is nothing out of the ordinary, but I get the same error as in the original pages. I have tried to add debug to my form action (layout_action.cfm?debug) but without any results.

I would be very thankful if someone can help me to solve this!

Hi all. I still haven’t solve this problem and what the reason can be that the <cflayout> and <cflayoutarea> combination as described in the quote is working off-line perfectly well but on-line is giving me the error as described. I have contacted my hosting company, with the question if it could be something in the settings of the server that needed to changed in order to make it work on-line as well, but haven’t received an answer from them neither. I’m still wondering if some of the Coldfusion pros here on Sitepoint can tell me if I am doing something wrong or who can tell me if there is something the hosting company need to change in the server settings.

I thank you all again in advance.