Chrome failing to start up

Hi all,

I have a lousy web connection so generally I try and use Chrome, however for a while now it’s been having start up issues. A window launches but just stays blank white so I have to close it and relaunch, sometimes it can take about 5 restarts to get it running.

I didn’t notice the problems coincide with any additions of new software and haven’t really added anything new in ages. I tried reinstalling but same problem, this is on XP.

My W7 laptop runs it just fine, had a quick look around the web but couldn’t find anyone with quite the same problem, anyone else have similar issues with Chrome or know about any software conflicts?


My chrome still doesn’t work. Google is dropping the ball for like the last 5 months. A quick fix is to right click on chrome icon > properties > at the end of the short cut path add --no-sandbox with a space before the --no > save and reload.

i have also facing the same problem thanks for pointing this and also for great suggestions

Try to uninstall the chrome, restart your computer, clean computer with the Advanced SystemCare 5, download fresh chrome setup, install… voila :wink:

Maybe some extensions are making your browser slow or check plugins running on chrome, that might cause problems too. I had similar problem, it needed a lot of time to load a website, i have deleted all extensions and disable most of the plugins i don’t need, restart the pc and everything was fine.

That doesn’t work. Untill they fix my solution is it

You actually have an option to try another browser, try to clean your cache or cookies first.


Not the most helpful advice, is it? If you went to a garage and told them your car wouldn’t start, you’d not be too impressed to be told to drive a different one, would you? :wink:

I actually tried to move from fx to chrome. Chrome has a nice mobile sync option. The a few weeks later it crapped out. So I’m still on fx. Love fx just a bit slow and a CPU hog. Chrome only works intermitidlty for me now. I download each new update in hopes of a fix and nada. There are some quite large threads around the internet. Google employees have chimed in too so they are aware of it. Only some have the problem so it must be a OS issue.

Mine seems to be working again.

You actually have an option to try another browser, try to clean your cache or cookies first.