Changing host default from php 4 to 5

I tried to run a oscommerce autoinstall php file
and I recieved an error that it works only from php 5.2

I looked in my hosts admin and there we have this info under general tab:

Basic Settings

When both PHP4 and PHP5 are enabled on the webspace, PHP4 is used by default for PHP applications. To use PHP5 as a default PHP engine, you should disable PHP4 on the webspace.
Name: www.s-24.ccccloud.com
IP: 109.226.3.81
IP Address type: Exclusive IP
Webspace location: 100124/
CGI support: On
SSI support: On
PHP4 support: Run as an Apache module
PHP5 support: Run as a CGI application
Error Documents: On
Webalizer Web Statistics: On
WAP support: On


and under CGI-bin tab:

The Common Gateway Interface is a way of connecting your web pages to other programs that are running on the server which visitors wouldn’t normally have access to. Most corporate web sites on the Internet today make use of CGI programs or scripts to allow their visitors to browse online catalogues or keep track of their orders in real time.

You have an ability to use CGI scripts on your website. The subdirectory "webspace/cgi-bin" located in your home directory is intended for storing your cgi files.

Before testing that CGI really works, devote a couple of minutes to read the information you might find necessary.
Paths and Versions:
Perl Version 5.8.1.
Path to Perl /usr/bin/perl
GID 48
Supported Extensions .pl, .cgi

Python Version 2.2.3
Path to Python /usr/bin/python
Supported Extension .py

Path to Sendmail /usr/sbin/sendmail
Operating System RedHat Linux

CGI Directory /cgi-bin/

The URL to your CGIs is as follows: http://domainname/cgi-bin/cgi-script
Replace the “domainname” with the real name of your domain and “cgi-script” with the script name.

Here are some tips for you to bear in mind when using CGI:
• Perl-scripts being transferred via FTP should be in “ASCII” code, not in “binary”.
• All scripts are executed only in cgi-bin directory.
• After uploading cgi-script change its permission to 755 (rwxr-xr-x). You can use an FTP client to do it.

Test: http://www.s-24.ccccloud.com/cgi-bin/test.cgi

It appears than PHP5 is not enabled if <? print phpinfo();?> shows that the server has php5 + already

Then you need to check if oscommerce does require php has to run as apache module, will it not work if php is run as cgi. I do not know, please check it.

Please disable php4 so that php5 will be the default php version to run oscommerce.