Can't get 'www' to show in URL (MAgento)

Hi everyone,

Apologies if this is posted in the wrong section or if it has been answered before, I appreciate its a pretty simple question.

How can I get my webpage to load so that it maintains the full url name ‘www.slippcases.com’ rather than downsizing to just ‘http://slippcases.com’ as it currently does.

The website will be developed fully on Magento - is it a case of Magento being installed onto the wrong folder in my directory?

Thanks for all your advice.

Tom :slight_smile:

I am not a server administrator but I think the best way would be to set it up in the http.conf (or something like that… as I said, no server guy and too lazy to have a look…).

If you want to do it the easy way, just tweak your .htaccess file


RewriteCond %{HTTP_HOST} ^slippcases\\.com$ [NC]
RewriteRule ^(.*) http://www.slippcases.com%{REQUEST_URI} [L,R=301]

Something like that should do what you want to achieve. Be aware that I do not know anything about Magento yet, so no liability for any errors…

Hi LarsK,

Thanks so much for replying to my post unfortunately even with changing the HTaccess file using your suggested code it is still coming up as just http://slippcases.com

I would be really grateful for more suggestions if anyone has a clue how I can fix this?

Thanks,

Tom :slight_smile:

Hey,

No worries now everyone! I have managed to fix it by changing the name in the magento database… Well my hosting provider did.

:slight_smile:

Glad to hear you got it fixed. For anyone else who may run into a similar problem check out www.webweaver.nu/html-tips/web-redirection.shtml, It is a great resource on redirects.
.