Can't access IIS using localhost

I was playing around with IIS 5.1 the other day and I noticed using the word “localhost” does not bring up the default site, in firefox it returns “No web site is configured at this address.” If I type in my ip address and port number it works, is this the normal behavior for IIS? I can use localhost with Apache webservers no problem, why not IIS?

Go to Internet Information Services and see if there is any virtual directory under the “Default Web Site” node. Also check if the website is running.

Just typing localhost will default to port 80. Always. Check which port IIS is listening on. You may have to append the portno to “localhost”.

The site is running, and I have opened a port for the server. I can access it using my IP appended with the port #, but it just doesn’t like localhost + port number, when I use IIS. Localhost seems to work fine with Apache, I don’t get why it’s not taking with IIS.

Which port is Apache running on? You cannot have 2 things running on the same port on the same address.

Apache is running on a different port, but I do have it disabled for now, so it’s not running at all.

which port# is IIS set to listen on?

447

Then type “localhost:447”

I do type in the port number if it is not listening on 80…

Here’s an example of what works and what doesn’t, so we are on the same page. <Don’t click on links, it’s just to show you what I type in>

http://localhost:447/Calc/testing.html <- does not work

http://192.168.1.100:447/Calc/testing.html <– works

Check the website properties in the IIS manager, check the IP settings, it should be (All Assigned), have a look at this thread http://forums.devshed.com/iis-97/iis-5-1-xp-pro-no-web-site-is-configured-254550.html

Your a genius Mike! That did the trick, thanks for sticking in there :slight_smile: and thanks to everyone else for their help.